2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 20 of 142 Posts

·
Registered
Joined
·
419 Posts
By uninstalling pause_on_mute, the original file will be copied again, depending on FW .230 or .511 and only for these two FW versions.
If you have another FW, the installer does nothing, the uninstaller too.

I uninstall and install near every tweak several times for testing and everything was fine all the time.

So I don't know, why mute is not working after that.
Hi siutch, I have the file for the pause-on mute for the 56.00.100A ADR.
 

Attachments

·
Registered
Joined
·
419 Posts
Thanks.

But it's the same file as the patched one for 56.00.230

Can it be, that you installed already the pause_on_mute tweak with an older version of AIO?
An older version than 1.40 has not yet checked, which FW was installed and copied the patched version, that comes from 56.00.230.

Since then AIO check during installation, which FW is installed, but only for 56.00.230A EU and 56.00.511A EU I have patched common.js files and only for these both version it will be copied.

I need an unpatched original version from 56.00.100A ADR to compare the files and make an extra version.

Thanks.
Hi Siutsch, this is the original version of the file
 

Attachments

·
Registered
Joined
·
419 Posts
Hi guys, i dont know if i fell behind on the posts but was the issue resolved for when you enable touchscreen while driving causing problems with the compass getting stuck?
I've tried to open the *.so file and it has a section where it looks if the speed restriction is enabled. I tried to search where is this value set, but I haven't been able to find it.
 

·
Registered
Joined
·
419 Posts
I've been testing the infortainment and it's possible to play flv and wmv videos. For the mkv we need to put a plugin first. I've made some small changes to the logic in the video player, and hope I post then today or tomorrow.

The pause for the videos is a little bit more complicated because we need to call directly the gstreamer objects. I would be testing some of this soon.
 

·
Registered
Joined
·
419 Posts
Small changes to the speedometer

Hi, I've made some small changes to the speedometer and the video player. I've separated the two apps making them independent.

For the speedometer:
1. The small status bar speedometer is now showing the "vehicle speed", it was showing the GPS speed, so it wasn't working when you were in the basement.
2. The retrieve process of the GPS data was made in four calls, this was changed to only one call, so I guess it should use less resources.

For the video player:
1. The search for videos searches only the usb devices that are connected. including those that doesn't have the "1" at the end. I was having issues with some usb due to this.
2. The WMV and FLV formats have been included
3. EDIT: It also now searches the 'Movies' and the 'movies' folder

Hope you can help me testing it. I have a Mazda 3 and I'm not having performance issues with the small speedometer.
 

Attachments

·
Registered
Joined
·
419 Posts
Hi, is it possible to include in the speedometer PID's from the pcm such as infos from the DPF state ?
Thanks
I've tested and you can extract info like engine rpm, current gear, gear lever number, coolant temp and many I haven't tested yet.

Could you search the value in the /jci/smdb folder? I don't know if I can test this value since I don't have the diesel version.

If you want I can show you how to get the values via ssh.
 

·
Registered
Joined
·
419 Posts
Hello Siutsch, yesterday I installed Android Auto, installing only this app having the speedometer and video already installed (first app was spedometer and then video player). I had a problem with the AdditionalApps.json file because the speedometer line already had a "comma". Hope you can improve this with some of this code:

Code:
log_message "mod to /jci/opera/opera_dir/userjs/additionalApps.json"
count=$(grep -c '{ "name": "_videoplayer", "label": "Video Player" }' /jci/opera/opera_dir/userjs/additionalApps.json)
if [ "$count" = "0" ]
	then
		mv /jci/opera/opera_dir/userjs/additionalApps.json /jci/opera/opera_dir/userjs/additionalApps.json.old
		echo "$(cat /jci/opera/opera_dir/userjs/additionalApps.json.old)" | grep -v "]" > /jci/opera/opera_dir/userjs/additionalApps.json
		echo "$(cat /jci/opera/opera_dir/userjs/additionalApps.json)", > /jci/opera/opera_dir/userjs/additionalApps.json
		echo -e '\n\t{ "name": "_videoplayer", "label": "Video Player" }' >> /jci/opera/opera_dir/userjs/additionalApps.json
		echo -e "\n]" >> /jci/opera/opera_dir/userjs/additionalApps.json	
		chmod 755 /jci/opera/opera_dir/userjs/additionalApps.json
fi
You could also include the option to choose the order of the apps in the installer

Thanks for all the work
 

·
Registered
Joined
·
419 Posts
Advise with using $(document).unload

I just had a trouble when I tried to use the $(document).unload to make some things when a page (apps) unloads. My cmu entered in a boot loop. I was just calling a function to stop a script via websocket.

Hope you don't have this problem in the future.
 

·
Registered
Joined
·
419 Posts
New Version of the VideoPlayer (2.4)

A new version of the Video Player, It's just in test phase. You could help me test it. Here are the changes:

* v2.0 Initial Version
* v2.1 Included more video types (previous release)
* v2.2 Enabled the fullscreen Option (nor released)
* v2.3 Included the status bar and adjusts to play in a window (not full screen) (not released)
* v2.4 Included a shuffle option
* fixed the problem of pressing the next button rapidly
* The list updates automatically at start
* Option to stop the video when you go backwards (doesn't work well), but it stops the video, so it doesn't stays playing on the video in the background

Any comments and bugs would be welcome

*******Removed file to avoid problemas as it didn't have version check*******
 

·
Registered
Joined
·
419 Posts
or a FastForward / pause function? *dream*^^

I want to say thx to everyone you did/do a create job!!

@Siutsch: There was a CMU App were you can choose a background image. So you can choose an other background every tine you drive. Do you know if this is already working and are you planning to import this. It was at the Infortainment project thread (approx. 1 month ago)
This shouldn't be so difficult, I'll see if I have some time to do this.
 

·
Registered
Joined
·
419 Posts
Are you able to confirm the video player works with 56.00.513B EU please? I can't get it to search for videos.

Thanks
Are you able to get into the cmu via ssh? The app doesn't do anything except lists from the Linux OS, so there shuldn't be any problem.

If you are able to enter, if you enter the /mnt dir, could you do the "ls" command and give us the results
 

·
Registered
Joined
·
419 Posts
You are awesome!

My speedometer/compass still doesn't work but it's all in the correct language.

How do I add my own image to the background? I have been fiddling around with it but can't seem to find out how.

Thanks a bunch!!
In the AIO there is an option to do this. In the USB replace the background.jpg file with the one you like :smile2:
 

·
Registered
Joined
·
419 Posts
The video App still requires the speedometer to be installed. This could be the problem. Since it uses JQuery, with I thought came with the CMU, but it's included by the speedometer. Check if you alse have the speedometer installed.
 

·
Registered
Joined
·
419 Posts
That's THE hint I nedded. :smile2:

Do you mean the folder /jci/gui/apps/_videoplayer/sh/js
and the file jquery.min.js in it?

And the videoplayer works if this folder and file comes together with installation of speedometer but in folder /jci/gui/apps/_speedometer/sh/js

Can you explain this a bit more please?
Yes, the js file in the videoplayer uses the funcion $() with simplifies the script about (1/3 the code lines), but it a requirement. I could check if I can modify the speedometer-startup.js a little to make it work with jquery as a independent file.

I will try to make this in the weekend, because I'm have a lot of work this week :s
 

·
Registered
Joined
·
419 Posts
New "test" version of Video Player

Hi, I didn't have much time to make this work, I included an option to add the jquery in the template (In the future it will check if it is already loaded by the speedometer). I've also added an option to unload the template (I've making some research an this option is already in some other native apps.

There are no new functionalities, just the option to use it when you don't have the speedometer :surprise:

Remember, it's just in test, I've been testing it for a couple of day, I hope you can help me. I want to use the speedometer again :p

UPDATE: removed the innecesary lines from the tweaks.sh (common.js file that was a test)

******Removed the file to prevent cmu bricks as it doesn't have a version check*******
 

·
Registered
Joined
·
419 Posts
Am I blind, or is there no common.js file in folder userjs?

Can you explain a bit more via PM, what I have to do, to be able to install videoplayer without speedometer?
Seems like I forgot that line from one of my tests :frown2:. The template loads the jquery directly from the addon-common directory.

I will be updating the file in a couple of minutes
 
1 - 20 of 142 Posts
Top