2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 19 of 20 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
My maintenance light (wrench symbol) on the dash lit up today. I checked the maintenance guidance on the nav system and there is no service interval low enough to trigger it. I just had the oil changed last week and my tire rotation is at 830 miles (and it shouldn't come on until 250 miles). Any idea why else it would come on. I found no help from the manual on why it would illuminate other than to remind of an oil or tire service. And unfortunately this doesn't produce a fault code so I can't figure it out that way either...hmmm...
 

·
Registered
Joined
·
81 Posts
Discussion Starter #4
How many miles do you have? It might be a reminder for the 10,20,or30k miles service.
I am just over 19,000 miles at this point. If the 20,000 mile maintenance is programmed in to the system, then there would be a way to reset it or it would show that the light is lit for the 20,000 mile maintenance, but this doesn't do that.

The light did go out earlier after the car was off for a couple hours. I'll keep an eye out for it again. For all I know it was a computer glitch from the infotainment system, much like all of the other little glitches that come from that thing.
 

·
Registered
Joined
·
412 Posts
Happened to me once as well. Ignored it for a couple days and it extinguished itself.
 

·
Registered
Joined
·
153 Posts
It is probably because the maintenance timer is also set for a time frame, and it wasn't reset when the oil was changed. You can turn that off somewhere in the maintenance section on the Infotainment, can't remember exactly what its called. I had this exact same problem, ended up going back to the dealer cause I thought I had checked everything, sure enough, even though oil maintenance was at 6800 miles and tires at 7000ish, the timer was set for 4 months, and it hit the 4 month mark... so yeah I felt stupid, lol.
 

·
Registered
Joined
·
28 Posts
I'm having this same problem. I tried resetting the maintenance items through the infotainment with no luck. it will be off one week and then back the next :-|
 

·
Registered
Joined
·
1,012 Posts
I have been having this issue for awhile. It will pop on for a day here and there then go away and come back and so forth.. I will have this looked at at my next oil change. I have had this issue since after my first oil change and I have 24K.
 

·
Registered
Joined
·
23 Posts
I too occasionally experience this issue. I think it is a software glitch. If I do a reboot on the Infotainment system, the wrench goes out (returns to normal function). I think software glitches are also responsible for the ADD occasionally not lifting up. I plan on getting the system version updated later this spring as I am on v27.
 

·
Registered
Joined
·
22 Posts
My maintenance light (wrench symbol) on the dash lit up today. I checked the maintenance guidance on the nav system and there is no service interval low enough to trigger it. I just had the oil changed last week and my tire rotation is at 830 miles (and it shouldn't come on until 250 miles). Any idea why else it would come on. I found no help from the manual on why it would illuminate other than to remind of an oil or tire service. And unfortunately this doesn't produce a fault code so I can't figure it out that way either...hmmm...
In owners manual, if you are within 250 miles ?? of the schedule maintenance/service the wrench light will come on.
 

·
Registered
Joined
·
36 Posts
My car is doing the same thing. I got an oil change/tire rotation about a month ago, all maintenance reminders were reset and about a week after that the light came on. No status in the maintenance or warning screens, just the wrench icon. Went off a few hours later after I stopped at a store and got back in, started the car it was out. Today going to work it came on again. oil life is at 90%, tire rotation life is at 3700+ miles remaining. Its just a software glitch. If its still on when i get home i'll hook up an OBD2 reader and see if there are any codes, but i doubt it, its a maintenance light, not check engine light.
 

·
Registered
Joined
·
30 Posts
Happened to me,

I found that maintenance reminder in the infotainment system is bugged. You need to reset the wrench light by holding the ignition button process described in the manual for it to go away.

Last time I had the software updated was August 2014.
 

·
Registered
Joined
·
249 Posts
It's the oil change maintenance issue. Change it to fixed instead of flexible and that should fix the issue.

For some reason mine kept coming on and off whenever it felt like, but would not indicate a reason. I took it to the dealership and this was their fix for the issue.
 

·
Registered
Joined
·
251 Posts
Had a phantom light the other day myself. It's just a couple weeks since I had it to the dealer, then I did my own resetting of the maintenance interval. It went off after I turned the car off and did not come back. We'll see.

I am indeed running on Flexible oil change interval, but I set it to that over 7500 miles ago and it never came on in all that time. So that is odd if this is supposed to be an ongoing software bug of some kind.

I wonder if infotainment version changes actually fix this? I'm on v30 still, came with the 2015 car I got in September.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #15
I've been experiencing this problem a bit more frequently lately. It comes on, then may stay on after I shut it off and on again, or it goes away and comes back a week or 2 later. I have never had a software upgrade on the system. I think I'm still v29 (haven't looked in awhile). Just one of the other numerous glitches I have on my list now. Such a good car burdened with these gremlins!
 

·
Registered
Joined
·
1 Posts
having this issue myself and there is no service due and I have 9k miles. I noticed that when it's on (doesn't always happen) my daytime running lights are inoperable.
 

·
Registered
Joined
·
574 Posts
I went through and turned all the normal maintenance items off in my car long ago and set the oil to variable after my last oil change. However, I had that wrench pop up the other day while driving down the road. I couldn't find any messages either and I verified all the maintenance reminders were as I had last set them. After I left work though, the wrench was off and stayed off.

I do wonder if maybe I got some bad gas because my MPGs haven't been as high as they normally are. I haven't noticed the normal stutter or rough idle that you'd normally see with bad gas though. It's the only thing I can think of though.
 

·
Registered
Joined
·
13 Posts
Hello

I had this problem too. The "oil service due" messages appeared after i started the engine just for some second. It happened at the first time at ~9000 km (intervall is 20.000). When i called the dealer he told me that they know about this problem, and will repair it when i will go to the next oil change. At this time they did something and the problem is went away. But i noticed that in the info screen no dynamic oil service option. I just see that i have back ~18000 km for the next oil change period but no percentage value. So may be they disabled the dynamic oil period option.
 

·
Registered
Joined
·
73 Posts
I've been having this issue as well the last couple days where the wrench icon will turn on for a few seconds before turning off, usually just a little while after I've started the car and started moving. The only Maintenance I have turned on in Infotainment is the flexible oil schedule, which has been stuck at 50% for at least 2000 miles. As I'm near 7500 miles and used Mobil1, I was planning to change the oil soon anyway, but I'm curious whether the oil life is actually lower and Infotainment mistakenly displays 50%. (I know that flex isn't even supposed to be accurate for non Mazda/Castrol oil, but I was curious.)

I'm also right on the cusp of 20k miles, so it could also be a reminder of the 20k service due? I guess I'll see in a few weeks after I've changed the oil if this goes away.
 
1 - 19 of 20 Posts
Top