2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Don't know if anyone has run into this with there 3 or not. My wipers will stop in the middle of my windshield. It only seems to happen when it is cold. Is this a wiper motor problem or is it a relay switch? I know the Ford Focuses had relay switch problems. That did this and I think the 3 and the Focus are related. Any ideas?
 

·
Senior Member
Joined
·
1,091 Posts
Reminds me of the SpeedSource's RX-8 at the Rolex24 in Daytona. The wiper blade was stuck in the middle position.



Needless to say, sounds like it could be a relay issue if temperature is having a measurable effect on it. I haven't had any problems and I've used them quite a bit here in California already but the coldest it gets is in the 40s.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
It is definitely a temp issue. It did it last winter, but then went back to normal once it warmed up. Unfortunately I live in Pittsburgh, PA so it tends to get a little cold than sunny CA. :) That pic is exactly what mine is doing. Very annoying. Thanks for your posts
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Ok now that I know that it is he relay. Do you have any idea which relay it is? Nothing in the manual specifically says wiper relay or what each relay controls.
 

·
Registered
Joined
·
155 Posts
Actually I had a similar problem with the switch not responding to when i changed the speed. But it only did it when it was really cold out. Also my automatic window didnt work this winter!HMMM?
 
1 - 6 of 6 Posts
Top