2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 2 of 2 Posts

·
kpo
Joined
·
1 Posts
Discussion Starter #1
Here is my issue: I bought a used 2013 Mazda 3 GT (took it to a Mazda dealership before buying for inspection, they said everything looked good) but now having it for a week, I have realized neither the auto lights or auto windshield wiper functions work. Both have AUTO on the control stick and when I move it to that position nothing happens. The lights work in the On positions and the wipers work in the Fast, Faster, and Mist positions, but neither work in the auto position. From what I can find online, the rain and light sensor should be in a separate box thing next to the rearview mirror? The car does not have this box but i do see a small notch in the linings above the rear view mirror where it looks like a cable should be. So it looks like the box was probably removed. But it also doesn't look like there is any spot on the windshield for it to go. Maybe the windshield was replaced too? My question is first: Is there any way to get the intermittent function to work for the wipers in place of the auto rain sensing function? Second: would it possible to just get the rain sensor box (found it for a little over $200 online) and attach it to any windshield? Or would it need to be the specific windshield for the rain sensing function? Also is the sensor for the auto headlight function in the same box as the rain sensor? is there a way to get that up and working without the rain sensor?

Thanks,
kevin
 

·
Registered
Joined
·
30 Posts
The auto for headlights will only come on when it reaches a certain darkness level. For the rain sensing wipers, there should be a little black box with a wire near the rear view mirror on the passenger side. If there isn’t a box, either didn’t have this option or windshield was replaced with a non sensing one.


Sent from my iPad using Tapatalk
 
1 - 2 of 2 Posts
Top