2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey! So I recently replaced my engine filter, after I did, the engine was making an unusual noise. After about a week of driving the car began to make the noise every time I accelerated and felt like it was struggling. I checked to see if I put the filter in upside down or if there was anything wrong with the filter itself. Nothing.

All I know is that after I changed the engine filter, the car doesn't feel as "peppy" when I drive.

Oh yeah, I Have a 2014 Mazda 3 S Grand Touring with around 28k miles.

Thanks!

Tom
 

·
Registered
Joined
·
109 Posts
curious what it sounds like from inside the cabin or engine bay - does it make the noise even while in park and just revving?

maybe the airbox didnt properly latch closed? Did u use an oem filter? or something like a k&n? or random cheapo part?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Weird engine noise

When the car is idle, it doesn't make a sound. It sounds as if air is struggling to get into the engine fast enough, but I honestly do not know.

I looked at the filter compartment a bunch of times and it seems to of closed properly. I bought the filter from an auto parts store it wasn't the OEM filter, but it also wasn't a cheap offbrand filter.
 

·
Registered
Joined
·
176 Posts
Check to ensure it is latched all the way. It should slide in backwards into lkittle slots and the front clips should easily clamp on. If that's ok, look around to see if anything is "not right" from before the air filter change. Also you might want to look at the air scoop right in front of the engine bay for any kind of blockage.
 

·
Registered
Joined
·
146 Posts
Check to make sure the ducts are in place and not kinked, crushed, or leaking, especially the one between the airbox and manifold. A kink could restrict airflow, and a leak could let air in behind the MAF and cause the engine to run lean.
 
1 - 5 of 5 Posts
Top