2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

41 - 45 of 45 Posts

·
Registered
Joined
·
138 Posts
Let me tell you my story:

  1. I mentioned the issue two weeks after I got my car (Nov 2019)
  2. Dealer told me that there's an update that they would like to apply at my next visit (Jan 2020)
  3. Dealer forgot to update the system at my visit in March 2020. So I did it by myself (10047 EU). It doesn't solved the issue (as we all already known), so I informed the dealer again.
  4. Dealer called me that they have another update, which has solved the same issue for another customer. So I visit the dealer again in June 2020. After "the update" (still 10047) the behaviour was still the same. I informed my dealer again.
  5. Dealer called me, they were in contact with Mazda Germany and a representative or at least a technician from my dealer needs to see the issue (first time that they want to see it!). I had to visit them again. During my visit in August 2020 we were also able to reproduce the issue with another Mazda 3 2020. They promissed me to keep in contact with Mazda Germany.
  6. Dealer called me, Mazda said this issue is an phone issue, and has nothing to do with the Mazda Connect. I asked if I'm allowed to contact Mazda Germany by myself to explain them the error. They agreed.
  7. Contacted Mazda Germany via email in September 2020. They replied to me, that they could not do remote diagnostic. I've to ask my dealer an they had to contact Mazda Germany for further diagnostics. They said also, that they've never been contacted by my dealer due to this issue.
  8. I informed my dealer about what Mazda Germany said. My dealer promissed to take care.
  9. Yesterday I got an email from my dealer, that Mazda Germany needs now an video or at least some photos of that issue.
I would really like to know, if this is a delay tactic or if they even have no knowlege about this Mazda Connect software part. I mean, they can reproduce this issue with probably each Mazda 3 2020 and Android phone. Why do they need me to visit and visit them again? That costs my and their time. Really annoying.
 

·
Registered
Joined
·
2 Posts
Ugh kudos to you for being so diligent in getting them to say something. I went to my dealer and they told me this was "normal operation for the vehicle". No crap; it's normal in the sense that every Mazda3 will likely experience this issue, but it's WRONG. It's an oversight in the design of the software and I'm sure it can be fixed in a few lines of code. Someone just needs to do it.

I'm really enjoying this car but so far Mazda's customer service has been pretty awful. I also tried contacting their regular customer service line and they essentially told me "If the dealer says it's normal then suck it up".
 

·
Registered
Joined
·
5 Posts
Ugh kudos to you for being so diligent in getting them to say something. I went to my dealer and they told me this was "normal operation for the vehicle". No crap; it's normal in the sense that every Mazda3 will likely experience this issue, but it's WRONG. It's an oversight in the design of the software and I'm sure it can be fixed in a few lines of code. Someone just needs to do it.

I'm really enjoying this car but so far Mazda's customer service has been pretty awful. I also tried contacting their regular customer service line and they essentially told me "If the dealer says it's normal then suck it up".
I'm just checking in to see any updates and see we're in the same boat still, frustrating, I'm just glad I rarely use AA and just prefer bluetooth music generally.

Car companies just do this though, my former Ford Focus instead of auto connecting back to the phone via bluetooth, like every other car in the world you have to go through like a 6 step menu or use a voice command to switch to bluetooth audio... I probably said "bluetooth audio" close to 4K times in my ownership of that car and I can't imagine that would be something that difficult to fix, but they just left it that way. So I guess the fact that my M3 connect to bluetooth every-time is a god damn blessing.
 

·
Registered
Mazda 3 HB GT 2021
Joined
·
2 Posts
Any news? Recently I bought a new Mazda 3 HB 2021, this crap has the same f** issue and it is so annoying! Mine has the 11002 software version. So, we still have the same problem. I'm from mexico city and here, things are slower to resolve than you, guys 😔. I'm so disappointed.
 

·
Registered
Joined
·
199 Posts
Any news? Recently I bought a new Mazda 3 HB 2021, this crap has the same f** issue and it is so annoying! Mine has the 11002 software version. So, we still have the same problem. I'm from mexico city and here, things are slower to resolve than you, guys 😔. I'm so disappointed.
Issue still here. Probably won't ever be resolved based on how the head unit remembers previously paired devices.

Update to 11012 though, TSR will work when navigating using Google Maps at least.

Only way I can think of panasonic implementing a fix is to have an option to automatically pair audio and phone on head unit startup or auto-pair on AA disconnect.
 
41 - 45 of 45 Posts
Top