2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
If a phone previously connected to the Mazda3 (specifically the 2019+ with the new head unit) via Bluetooth (both media audio and phone audio) is connected to the Mazda using Android Auto via USB, then Bluetooth profile for the phone is immediately changed in MazdaConnect to DISABLE bluetooth audio for media - only bluetooth audio for calls remain, and it is not changed back when the Android Auto session is ended.

The implication of this is when the user starts up the car again, Bluetooth music is disabled. In fact to listen to any kind of Bluetooth music with the phone at all, the user has to go into the Mazda bluetooth settings, and manually disconnect the phone and reconnect and manually select both Calls and Media! This is a rather extreme inconvenience.

As far as I can tell, there is no technical reason why using AA needs to completely disable the Bluetooth media audio permanently...from my conversations with a few owners of 2018 and older Mazda3s they do not experience this behaviour, so it seems like a problem with the new head unit/software. Can anyone else confirm the same behaviour on their 2019 Mazda3s? I would like to file some sort of help request with Mazda but I don't know how to do that. I see on the MazdaConnect help website it does not list the 2019 Mazda3 as an option. I tried creating an issue on the official Google Android Auto forums here https://mail.google.com/mail/u/0/#inbox/FMfcgxwDrlbNslcMHgklMGzxgTwLQZdM but there has been no reply from any Google representative yet.
 

·
Super Moderator
Joined
·
4,971 Posts
Actually, 3rd gen cars had this issue with AA 2 or 3 years ago when the only way to have it on a Mazda 3 was install it yourself. The issue was fixed back then for the hacked AA version. It was the Mazda entertainment system software that was causing the problem, not AA. There is one lengthy thread discussing this and probably a lot more smaller discussions in the 3rd gen section. Sounds like the problem never got addressed in the current official version of AA.
 

·
Registered
Joined
·
213 Posts
I have not found the problem with Apple CarPlay. When I leave CarPlay bluetooth is reconnected.

Hope this helps narrow down the issue.

I was annoyed that I could not continue to connect to my second phone for calls when the data phone is plugged in. You have it much worse.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Actually, 3rd gen cars had this issue with AA 2 or 3 years ago when the only way to have it on a Mazda 3 was install it yourself. The issue was fixed back then for the hacked AA version. It was the Mazda entertainment system software that was causing the problem, not AA. There is one lengthy thread discussing this and probably a lot more smaller discussions in the 3rd gen section. Sounds like the problem never got addressed in the current official version of AA.
Interesting, I didn't know that...I tried searching through the 3rd gen forums but I couldn't find the thread(s) you mentioned, could you provide a link to them? Thank you.
 

·
Super Moderator
Joined
·
4,971 Posts
Long discussion on BT and AA conflicts
 

·
Registered
Joined
·
18 Posts
Just wanted to chime in that my 2019 Mazda3 Premium does the same thing. After I disconnect Android Auto I have to manually disconnect my phone, then go in and connect it and tell it just use Bluetooth audio to get it working again. It's a huge pain. Hopefully this is something that can be fixed via a system update.
 

·
Registered
Joined
·
163 Posts
Update: So I sent my log and some of the other threads to the service manager at my local dealership and he forwarded it to mazda canada & japan. They're working with Panasonic to fix the bug and there will apparently will be fixed in the next update. No eta on when Panasonic will release it to dealers though :/
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Update: So I sent my log and some of the other threads to the service manager at my local dealership and he forwarded it to mazda canada & japan. They're working with Panasonic to fix the bug and there will apparently will be fixed in the next update. No eta on when Panasonic will release it to dealers though :/
That's great news! I'm glad Mazda is working on it.
 

·
Registered
Joined
·
163 Posts
That's great news! I'm glad Mazda is working on it.
Well sort of, the reply I got back was more so "We've told Mazda Japan who told Panasonic about the issue. Wait for Panasonic to issue a firmware update. We don't have an ETA for the fix" lol

But better than nothing I guess
 

·
Registered
Joined
·
111 Posts
Hey, I've the same issue with mine Mazda 3 2019. Glad to found this thread and also that Mazda was informed about the issue. I will inform my dealer too so that Mazda will know that others have the same issue/pain.
 

·
Registered
Joined
·
38 Posts
Is there a way we can report this directly to Mazda vs going through a dealer that probably won't say that much.
If a phone previously connected to the Mazda3 (specifically the 2019+ with the new head unit) via Bluetooth (both media audio and phone audio) is connected to the Mazda using Android Auto via USB, then Bluetooth profile for the phone is immediately changed in MazdaConnect to DISABLE bluetooth audio for media - only bluetooth audio for calls remain, and it is not changed back when the Android Auto session is ended.

The implication of this is when the user starts up the car again, Bluetooth music is disabled. In fact to listen to any kind of Bluetooth music with the phone at all, the user has to go into the Mazda bluetooth settings, and manually disconnect the phone and reconnect and manually select both Calls and Media! This is a rather extreme inconvenience.

As far as I can tell, there is no technical reason why using AA needs to completely disable the Bluetooth media audio permanently...from my conversations with a few owners of 2018 and older Mazda3s they do not experience this behaviour, so it seems like a problem with the new head unit/software. Can anyone else confirm the same behaviour on their 2019 Mazda3s? I would like to file some sort of help request with Mazda but I don't know how to do that. I see on the MazdaConnect help website it does not list the 2019 Mazda3 as an option. I tried creating an issue on the official Google Android Auto forums here Gmail but there has been no reply from any Google representative yet.
I have a M3H 2020 and I can confirm that the same problem is still there. I can add, as far as I can see, that the problem won't show up if you do NOT use Pandora while in the MazdaConnect menu system and while AA is up and running. I can use all the other MazdaConnect menu items, even going into USB Drive to play music or video. As soon as I go into Pandora from MC the BT connection gets totally messed up and I have to Unpair and Pair again. My theory is that the BT connection is seized by both the MazdaConnect and AA at the same time and they collide. By the way, if you use Pandora from within AA, everything stay up. My workaround: Do not use Pandora from MC if you have AA. I use AA all the time, including for Pandora.
 

·
Registered
Joined
·
163 Posts
I have a M3H 2020 and I can confirm that the same problem is still there. I can add, as far as I can see, that the problem won't show up if you do NOT use Pandora while in the MazdaConnect menu system and while AA is up and running. I can use all the other MazdaConnect menu items, even going into USB Drive to play music or video. As soon as I go into Pandora from MC the BT connection gets totally messed up and I have to Unpair and Pair again. My theory is that the BT connection is seized by both the MazdaConnect and AA at the same time and they collide. By the way, if you use Pandora from within AA, everything stay up. My workaround: Do not use Pandora from MC if you have AA. I use AA all the time, including for Pandora.
What happens is that audio/media is routed via usb but the phone connection is maintained via Bluetooth. Unfortunately when you try to use Bluetooth the next time around or change inputs the car forgets the connected device can be used for audio as well and you have to go into settings and select your phone as the audio device manually.

In Canada we don't get Pandora but the issue is still there. Your case seems to be more isolated and you're lucky that it works that we'll. I end up using the Mazda NAV as AA disables TSR and doesn't integrate with the HUD.
 

·
Registered
Joined
·
38 Posts
What happens is that audio/media is routed via usb but the phone connection is maintained via Bluetooth. Unfortunately when you try to use Bluetooth the next time around or change inputs the car forgets the connected device can be used for audio as well and you have to go into settings and select your phone as the audio device manually.

In Canada we don't get Pandora but the issue is still there. Your case seems to be more isolated and you're lucky that it works that we'll. I end up using the Mazda NAV as AA disables TSR and doesn't integrate with the HUD.
Is your M3 a 2020 or older model?

The AA (CarPlay) integration is still in its infancy and has annoying bugs/limitations but we just find a work around that works for our individual cases. Soon Bluetooth is obsolete (for AA) and only WiFi will be used for the bigger bandwidth to replace both BT and USB connections. I read some luxury car brands (BMW, Mercedes) already implemented the WiFi method. That will soon spread to main stream brands too. Also important to know is that you will need a phone capable of doing AA over WiFi. Google Pixel and Samsung Galaxy S9 (and above) phones already support AA using Wifi. You just need a new(er) car ... soon.
 

·
Registered
Joined
·
24 Posts
I was wondering what the heck was going on - now I know.
Nothing to do with Pandora either... Pandora discontinued it's service in Australia a while back.

I guess for now I just won't use Android Airplay. Pretty stupid.
 

·
Registered
Joined
·
105 Posts
I have this obnoxious issue on my 2019 Mazda 3. I can not switch from using wired android auto to bluetooth audio without completely unpairing my phone and repairing it. I'm pretty much stuck using either bluetooth audio only or plugging in my phone every time.

I sincerely hope there's newer firmware that addresses this. I'm on 10017 and there's word that some cars are up in the 10040s
 

·
Registered
Joined
·
163 Posts
Is your M3 a 2020 or older model?

The AA (CarPlay) integration is still in its infancy and has annoying bugs/limitations but we just find a work around that works for our individual cases. Soon Bluetooth is obsolete (for AA) and only WiFi will be used for the bigger bandwidth to replace both BT and USB connections. I read some luxury car brands (BMW, Mercedes) already implemented the WiFi method. That will soon spread to main stream brands too. Also important to know is that you will need a phone capable of doing AA over WiFi. Google Pixel and Samsung Galaxy S9 (and above) phones already support AA using Wifi. You just need a new(er) car ... soon.
It's a 2020 on firmware 10042. The issue isn't present on the last gen mazda connect in our cx-5. There will be a fix eventually. Also yes AA over wifi will be the future however that is exclusive to only a few pixel and galaxy devices.
That will also however have it's own set of issues: Battery drain from high power usage, heat issues and power drain unless car manufacturers use actively cooled fast wireless charging pads (those will also be split between qc and pd), faster battery replacements in devices due to heat+excessive wireless charging, so in the end people will still end up plugging in their phones :")
 

·
Registered
Joined
·
163 Posts
I have this obnoxious issue on my 2019 Mazda 3. I can not switch from using wired android auto to bluetooth audio without completely unpairing my phone and repairing it. I'm pretty much stuck using either bluetooth audio only or plugging in my phone every time.

I sincerely hope there's newer firmware that addresses this. I'm on 10017 and there's word that some cars are up in the 10040s
v10042 and issue is still there, Mazda and Panasonic are aware of the bug and are working on a fix, no eta unfortunately.

Try this though as its less of a pain:
Go into settings > connectivity > bluetooth settings > select [your device] > change to phone and audio each time after using AA.
 

·
Registered
Joined
·
105 Posts
v10042 and issue is still there, Mazda and Panasonic are aware of the bug and are working on a fix, no eta unfortunately.

Try this though as its less of a pain:
Go into settings > connectivity > bluetooth settings > select [your device] > change to phone and audio each time after using AA.
Thank you. I was wondering how you were doing that

The dealer flashed my car from 10017 to 10018 today and I was just kinda confused and wondered why I even bothered. Either they're behind other dealerships or 10018 is the current firmware for my vehicle in the US. As you said, any of the current firmware versions probably won't fix the issue. If going all the way up to 10042 doesn't fix it either I'm just going to have to wait until we get an update that addresses it. Again, I wish we could get changelogs. I'd be happy to maintain a thread with them if I had a source.

I didn't bother pushing them to send up a report to Mazda seeing that they're aware of it. If anyone thinks it'll help for more people to complain I will do so
 

·
Registered
Joined
·
163 Posts
Thank you. I was wondering how you were doing that

The dealer flashed my car from 10017 to 10018 today and I was just kinda confused and wondered why I even bothered. Either they're behind other dealerships or 10018 is the current firmware for my vehicle in the US. As you said, any of the current firmware versions probably won't fix the issue. If going all the way up to 10042 doesn't fix it either I'm just going to have to wait until we get an update that addresses it. Again, I wish we could get changelogs. I'd be happy to maintain a thread with them if I had a source.

I didn't bother pushing them to send up a report to Mazda seeing that they're aware of it. If anyone thinks it'll help for more people to complain I will do so
10042 is on the 2020s shipped from Japan

You should open a case at your dealership as more complaints = higher priority to get a problem fixed.
 
1 - 20 of 32 Posts
Top