2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
I have 2014 sgt, last week I upgraded all my turn signals front and back to led. Today left turn click sound on dashboard super fast(Hyper flash?).Then I found out both front and back on left signal don't light up no more, even wit hazzard light on. Right works just fine. What could be the issue? bad led resistor, or led burn my left wire? I belive both sides are controlled by same fuse, while right is still working means fuse is fine. Anyone experience same thing with newly led upgraded? Thanks
 

·
Super Moderator
Joined
·
6,385 Posts
Check the bulbs for functionality.
Check the bulb sockets to see if there is power.
Replace the LEDs with incandescent bulbs to see if the circuit still works.
 

·
Registered
Joined
·
570 Posts
Check the bulbs for functionality.
Check the bulb sockets to see if there is power.
Replace the LEDs with incandescent bulbs to see if the circuit still works.
Not all LED's are created equal (as the general LED technology is still greatly evolving) and you should know if your system was not initially designed for LED's then you should not be surprised by potential issues...not to say that most can not be overcome either by changing a relay or trial and error with different LED's. Just as a simple example, when I upgraded all my 2017 3 hatch GT's fuse style interior lamps to LED's, I had the one LED in the hatch area not turning off when I closed the hatch. In fact it was one of the issues I had previously read about in a car lighting forum that some LED's will continue to stay on prior to installing. When I changed out that LED with another LED, it worked fine.
 

·
Super Moderator
Joined
·
6,385 Posts
Cheap Autozone type LEDs can play hell with the canbus at times. I swapped all the lighting in my car for LEDs last year with good quality stuff from iJDMtoy and JDM Astar mostly. Resistors all around, no canbus error bulbs with built in resistors in the front signals. So far no issues.
 
1 - 5 of 5 Posts
Top