2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I installed my TWM full shifter replacement earlier today, and I noticed there's a ton of shifter play when in neutral or in gear. While in neutral, I can move the shifter using very light pressure in circles without engaging it into any gear. Likewise, while in gear, I get like an inch of wiggle room without actually disengaging from any gear. I presume something went wrong in the middle of the installation, where you have to align the fore/aft, back/forth, and the reverse lockout plate. The excess play/dead spots pretty much negate the short throw.

As of current, my throw is more or less stock length (most of the distance being excess shifter play), with a solid notchy engagement at the end of the throw.

My shifter also appears very off-center. Being in neutral almost looks like I'm in 4th/6th gear. Also, the amount of side-to-side while in neutral is uneven - I can move the shifter a few inches to the right, but I only have a centimeter or so of play on the left side. And if I do move the shifter left, it does not rebound back towards the center like you would expect.

I had issues with the reverse lockout plate positioning. The instructions to say to move the plate all the way to the left, then shifting into 1st gear and adjusting the plate so that it touches the pin on the shifter. The problem with this is that when I thought I was shifting into 1st, I was actually shifting into Reverse. So I moved the plate a little more right, until I was lined up with 1st and 2nd gear, and tightened it down there. But the plate's new position is probably part of the cause why my side-to-side play is so uneven - the shifter is hitting the lockout plate before travelling the whole distance.

Anybody have a similar experience when first installing their full replacement? Hopefully some Mazdaspeed junkie is awake at this hour and can lend some advice. I'm at work, so I'll be popping in intermittently, but I want to get this fixed right after I get off
 

·
Registered
Joined
·
596 Posts
This is the exact post as on the real speeders forum, do you think you are going to get better info here. I believe you are getting some good advice over there. Nothing against this forum, but the better technical support is over there as well as calling/PM the Canucks. Starting my install tomorrow morning.

TWM Full Replacement Dead Spots/excess play? - Mazdaspeed Forums

Z

Edit - Glad to read you found your problem, with all the R&D and my money that went into this piece, I was hoping there were not alot of problems.
 

·
Registered
Joined
·
5,636 Posts
This is the exact post as on the real speeders forum, do you think you are going to get better info here. I believe you are getting some good advice over there. Nothing against this forum, but the better technical support is over there as well as calling/PM the Canucks. Starting my install tomorrow morning.

TWM Full Replacement Dead Spots/excess play? - Mazdaspeed Forums

Z

Edit - Glad to read you found your problem, with all the R&D and my money that went into this piece, I was hoping there were not alot of problems.


Hey Price I suspected you were a dick and you just confirmed it. Why is this not a real forum and why shouldn't he try to get his problem solved on several different forms? Looks like your sponsored by TWM and fuck your money too. The world doesn't revolve around MSF. Sounds like the banter on MSF went to your head and you've become a wanna be Lenny or Philly b. Punk bitches like you piss me the fuck off!
 

·
Registered
Joined
·
596 Posts
why thank you, facts are facts, and I believe you made the same statement and I quote "I guess right now I'm the newest at MSF. I just traded in my 2.5 hatch for a 2010 LS Genpu last week. This forum rocks! I don't see a need to go anywhere else for quality info. It's all here. Nobody needs to see another pic of a bone stock genpu with tint so I threw up a pic of my old ride. Oh yea, I donated and I have a cp-e rmm and some JB ssb's on the way. Life is good!"

Newest noob - Mazdaspeed Forums

Do I aspire to be someone I am not, not really, I do find their comments to be rather humorous, similar to rhetoric above.

Z
 

·
Registered
Joined
·
5,636 Posts
I didn't dis this forum nor did I try to steer anyone away from here in that post. That's your fail bro.
 

·
Registered
Joined
·
2,771 Posts
This will be a fun thread to watch for a while!

:popcorn:
 

·
stupid teacha bitch!
Joined
·
2,193 Posts
i agree with warlord people look to this formum for friendly advice from people who have either handled these situations or are also encountering them so back off a lil man leave the thread alone if you think its stupid let someone who is willing to help him help and leave it be
 

·
Registered
Joined
·
2,771 Posts

·
Registered
Joined
·
5,636 Posts
I didn't take a nap today. I was cranky.
 

·
Registered
Joined
·
596 Posts
BSUBigMac sorry to disappoint last evening, but dinner, cocktails and spirited OPINIONATED conversation was calling.

I found it funny that the OP never chimed back in, I guess he got his answer somewhere else and he also figured out that the shift plate was installed in properly causing the majority of the issues.

I have reviewed my statement which was as follows "do you think you are going to get better info here. I believe you are getting some good advice over there. Nothing against this forum, but the better technical support is over there". I did not state this forum was crap, I did not DIS anyone, all I stated was THAT IN MY OPINION BETTER TECHNICAL SUPPORT IS ELSE WHERE, will this continue I hope not. When did someone become a DICK for stating their opinion, forums are the place for discussions and the gathering of information, which includes opinions on all topics.

Just because my opinion differs from yours is no reason to become a jackass about it. We have many enthusiastic conversions in our Mazda Club, but you are never a DICK for expression your opinion. If you don't like differing opinions I might make a suggestion, relocate to some other country.

And sp33dy1013 by the time you chimed in, as well as warlord, the OP had the resolved the issue with several suggestions from other sources.

Z, Opinionated Dick
 

·
Registered
Joined
·
5,636 Posts
Your conveniently omitting your original statement from your last post. To quote you: "This is the exact post as on the real speeders forum". You don't consider this a dis against this forum? What business is it of yours where, when and why the op asks questions. You chastised the op for asking over here. I still don't fucking like your original post. Admittedly the MS3 part of this forum is small but it will never grow with asshole comments like that. Your a small fish in a big pond over on MSF. Your a big fish in a small pond over here. If you care at all about this forum maybe you will help it grow instead of trying to intimidate people from posting over here. Your original post also reeks of conflict of interest which doesn't belong on a forum to begin with, but I won't delve into that now.
 

·
Registered
Joined
·
596 Posts
You nailed it on the head, the majority of posts, thoughts, comments, walk-throughs are for MZ3 and that trend does need to be corrected. I don't read for a day or so come back and there are minimal posts for the MS3 platform. Do I like the folks here, of course, beats catching alot of crap for a stupid comment. But after awhile seeing new post after new post concerning painting emblems or how do I fix my AUTO windows does get tiresome.

Do I prefer reading and getting information concerning HP over eye candy, most definitely, who wouldn't. When new products come to market for our platform, where are they posted, where is the most updated information concerning the GENPU, when you answer these questions, then my comment is correct.

Don't want to be a fish period, small pond or large pond, just want good knowledgeable information, unfortunately and I do say unfortunately, at this point in time the best information tends to be in other locations. Have I attempted to bring some of that info here, no I have not, will I moving forward, probably so. I have actually had some members ask for non-released GENPU stage 2 AP Maps of which I have access to and were sent without thinking twice.

You can also read alot of things into the written word, that is why interpretation of many books is dependent upon who is reading them and their background.
 

·
Registered
Joined
·
5,636 Posts
Well, you have more passion and heart that than I originally expected. Maybe you'll reserve some of it for this forum. Beween this forum and MSF I don't much else out there. No doubt it's tricky posting in MSF. Alot of Genpu haters looking to pounce and people with so much experience with boost that they take their knowlege as a given that everyone should know already. 247 is mainly old Protege owners and M3F doesn't have much for MS3 owners escpecially Genpu owners. Matter of fact M3F looks like it's on the fast track downhill since it was sold. Vendors don't even post there anymore. Well to each his own . I'm done posting in this thread.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #16
I have been more active on MSF as of lately, so I haven't chimed in. Nothing against any of the other forums, but I'm starting to prefer it as my source of info/discussion on the MS3. Mazda3forums was my board of choice when I was actively tinkering with my 3i. I still browser all three boards (MSF, M3F, M3R) for info. I'm actually here because I'm reading up on SRI comparisons, which I couldn't find on MSF :tongue:

Now, about my shifter problem. I eventually found out that I had the TWM transmission adapter mounted very wrong. Being mounted wrong, it loosened the mounting screws,and thus, there was a lot of slack left in the shifter cable before it could actually switch gears. Actually, the next morning, the transmission adapter completely fell out while in 4th gear, and I had to call a tow truck to bring me home. Thankfully, he had a set of tools on him, and I was able to fix the improperly mounted TWM transmission adapter.

Long story short, user install error was the culprit. :stuart:
 

·
Registered
Joined
·
596 Posts
^^^^Read that you had found the problem before the conversation started and knew you had found the issue. Got lazy last weekend did not install mine, studying this weekend, probably next weekend for this, as well as so needed maintainence, RSB grease, tranny fluid change, tire rotate, etc.

Were the instructions for both pieces clear, I have read them a couple of times and seems very straight forward with both pieces. What caused you to get the plate on incorrectly?

Z
 

·
Registered
Joined
·
20 Posts
Discussion Starter #18
^^^^Read that you had found the problem before the conversation started and knew you had found the issue. Got lazy last weekend did not install mine, studying this weekend, probably next weekend for this, as well as so needed maintainence, RSB grease, tranny fluid change, tire rotate, etc.

Were the instructions for both pieces clear, I have read them a couple of times and seems very straight forward with both pieces. What caused you to get the plate on incorrectly?

Z
The instructions were clear, I was probably just rushing to get the job done. The part where I screwed up was in step 13 here:

http://www.twmperformance.com/manuals/2010-mazda-speed-3-installation-manual.pdf

See the left side of the picture, where the end-part of the TWM plate sits UNDER the two screw holes on the shifter mechanism? I initially had the plate mounted on TOP of the holes, so that made the whole plate crooked. Crooked plate = bolts easily loosened themselves during driving = epic fail.

Don't get me wrong, this is a simple install. I just somehow manage to screw something up every time I do something to the car LOL
 

·
Registered
Joined
·
115 Posts
I belong to both forums. That said, I always try to get my answers here first. I believe there is a snobish, no noob approach to the other forum. We all must learn somewhere. That is why I prefer to ask my questions and bounce ideas off of people here, first. That said, there is definitely more technical information there, if you are willing to be insulted to get it. So in essence you are both right. I would love to see this forum have the technical base of the other, but with this forum's attitude toward learning!
 

·
Registered
Joined
·
596 Posts
The instructions were clear, I was probably just rushing to get the job done. The part where I screwed up was in step 13. See the left side of the picture, where the end-part of the TWM plate sits UNDER the two screw holes on the shifter mechanism? I initially had the plate mounted on TOP of the holes, so that made the whole plate crooked
thanks, I did see that when reading thru, one issue is that instructions sent are black and white, this has caused me issues in the past, this is why I print them out in color.

I belong to both forums. That said, I always try to get my answers here first. I believe there is a snobish, no noob approach to the other forum. We all must learn somewhere. That is why I prefer to ask my questions and bounce ideas off of people here, first. That said, there is definitely more technical information there, if you are willing to be insulted to get it. So in essence you are both right. I would love to see this forum have the technical base of the other, but with this forum's attitude toward learning!
I belong to both as well, and after receiving a tongue lashing from warlord have decided to be a little softer over here. I do agree the technical expertise is higher over there but plan on attempting to pull information from there over here when things arise. The key over there is research before you ask, I do agree with that idea, as there are too many threads that are the same here due to laziness.

Z
 
1 - 20 of 21 Posts
Top