2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Very upset! Brand new '17 Mazda 3 GT. Not even 200 miles on it. I was swapping out interior, license plate, and reverse lights for LED bulbs and all I had left was the trunk. The LED strip I got off Amazon was too big and stupid me thought it would be a good idea to try and force the adapter into the hole.

It is a pain to fish this out of the metal housing and get it back in place but the clips are ruined now. The thing is made with very flimsy plastic that breaks super easy. I can't even plug the stock bulb back in without the thing going back up in the metal again. What options do I have here? If I have to take it to the dealer any idea on what they will charge? If there is just a negative and positive wire behind this clip I wouldn't mind tapping directly into it for my strip but I'm afraid to pull it any further out. Pictures: imgur.com/a/khaHR
 

·
Registered
Joined
·
3 Posts
Very upset! Brand new '17 Mazda 3 GT. Not even 200 miles on it. I was swapping out interior, license plate, and reverse lights for LED bulbs and all I had left was the trunk. The LED strip I got off Amazon was too big and stupid me thought it would be a good idea to try and force the adapter into the hole.

It is a pain to fish this out of the metal housing and get it back in place but the clips are ruined now. The thing is made with very flimsy plastic that breaks super easy. I can't even plug the stock bulb back in without the thing going back up in the metal again. What options do I have here? If I have to take it to the dealer any idea on what they will charge? If there is just a negative and positive wire behind this clip I wouldn't mind tapping directly into it for my strip but I'm afraid to pull it any further out. Pictures: imgur.com/a/khaHR
Sorry to resurrect the old post but I got the same problem. Were you able to fix it? if yes, how? I also managed to pushed it in and now can't figure out how to fix it. Thanks!
 
1 - 2 of 2 Posts
Top