2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hey guys just had my tripoint engineering sway bar and endlinks installed ny my mechanic. Now when i go over bumps it sounds chunky almost as if my endlinks are bad. I had my mechanic look at it and he said everything is fine. Is the noise caused from upgrading rear end links from oem to tripoint one and its just the endlinks doing there job. Idk kind of frusterated.
 

·
Super Moderator
Joined
·
6,186 Posts
Clunks are usually from the RSB not being greased and the end link nuts not being torqued down properly.

RSB torque specs:

End link top nut torque: 33-44 ft lbs
End link RSB nut:
-MZ3: 33-44 ft lbs
-MS3: 60-70 ft lbs
Bracket nut: 31-39 ft lbs

What torque specs did the tripoint install instructions give?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
So i had the mechnic retighten everything and greese the bushings still a little chunky in back. I went under the car and he showed me everything. Is a rsb with metal end link just a little noisier than oem. The mechanic said the noise im hearing is the end link twisting a little when i go over bumps. Car turns on a dime now and rides great just a little noisier.
 

·
Aspiring Mad Scientist
Joined
·
1,716 Posts
I'm thinking your mechanic didn't tighten the endlinks properly, with the allen key in the stud to keep it still. The tri point rsb does have a pretty thick arm so it's easy for the endlink nut to back out too. I experienced this myself with the same bar.
 
1 - 4 of 4 Posts
Top