2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I've owned my 2013 Mazda 3 Skyactiv Hatch for a few months now and since I bought it the traction control light is always on. Is this a common issue? Any ideas on how to fix it?


 

·
Axela AWD driver
Joined
·
116 Posts
What happens when you press and hold the TC button?
Does it go away? Does it flash?
Have you tried disconnecting the battery for 30 minutes?

If it's always on, there may be a problem with a speed sensor or ABS module.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
290 Posts
Ditto it might be an ABS sensor on one of the wheels that needs to get replaced

see if you can get someone with an advanced scan tool to check it and see if they can pinpoint the problem.
A regular scan tool might just give you a generic error code.

From there see if you want to fix it yourself or have a shop do it
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
What happens when you press and hold the TC button?
Does it go away? Does it flash?
Have you tried disconnecting the battery for 30 minutes?

If it's always on, there may be a problem with a speed sensor or ABS module.


Sent from my iPhone using Tapatalk
Nothing happens when I press or hold the TC button. I'll try disconnection the battery.

Should I take the car to the dealership to scan or find an individual mechanic?
 

·
Axela AWD driver
Joined
·
116 Posts
Nothing happens when I press or hold the TC button. I'll try disconnection the battery.



Should I take the car to the dealership to scan or find an individual mechanic?


I suspect it's a wheel speed sensor(abs sensor).

It shouldn't cost too much to get it replaced.
If you're on a budget, take it to a local shop to find out what the problem is, then order the part online and replace yourself.
The sensor are easy to replace, or it could even be just a lose connector.
 
1 - 5 of 5 Posts
Top