2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
6501 - 6520 of 6524 Posts

· Registered
Joined
·
2 Posts
Hi,
I'm using some of AIO tweaks and they are great.
It inspired me to think if it would be possible to add speedcams as you drive when you see them and started to work on a solution.
And there it is!
Recently I've developed TravelPal, a free App that presents travel data AND lets create custom Speed cameras on the fly and select speed limit. App will provide alert when you pass them again.
It works even if there's no Navi SD card. App uses well known list speedcam.txt if it exists or creates it's own. Redundant speedcams can be removed from the list.
The App works very well on my 2015 Mazda 6 with FW 56.00.100 EU.
It uses EU/US units and can be adapted to any local language by adding translation to lang file.
It would be great if anyone could try it on other cars in Europe and US.
App uses pure javascript and shell script to transfer data through websocket.
All necessary files to install and also some screenshots can be found on my github/pitrock2000, link:
GitHub - pitrock2000/TravelPal: Travel Info and User Speedcams for Mazda Infotainment System

Thanks to All who created original tweaks.
Please let me know your thoughts or questions.
 

· Registered
Joined
·
20 Posts
I'll be getting this in on Thursday, they provide the necessary update on USB as part of the kit.
 

· Registered
Joined
·
2,555 Posts
One thing bothers me at this offer... for this official AA/CP you need to install any FW 70 or higher. But if you have FW 31 - 56.00.100 NA Mazda officially recommends to install 70.00.100 first, before updating to a higher version (like 70.00.367 or 74.00.230). And this they do not tell you in their offer. So I would check which version I have installed. If it is between 31.00.100 - 56.00.100 I would install 70.00.100 first, before updating to a higher version, which maybe is on their offered usb stick. Just saying, that you can avoid problems with or even bricking your CMU.
And if you have a version installed below 31.00.100 then update to that one first.
 

· Registered
Joined
·
3 Posts
New to the forum. Looking to install a Genuine Mazda Android Auto/Carplay upgrade in my mother's 2017 CX-5. Her current firmware is 59 (don't have the exact version in front of me, but I know it's 59). What would be the best firmware to update it to? This is in North America. Thank you!
 

· Registered
Joined
·
405 Posts
Hi, everybody.

I got a log from the console that says:

Code:
Jan  1 00:01:02 vim_app: [000.00:01:02.326027677], VIM, 235, vim_app, 235, Warn, IUC.c, IUC_SPI_PopTxMessage 1691, Pop message from TX queue. ID 0030, 00 B
Jan  1 00:01:06 reflash_app: [000.00:01:06.000153344], REFLASH, 236, reflash_app, 236, Info, reflash_app.c, reflash_app_Update 2961, Progress: 99%
Jan  1 00:01:06 vim_app: [000.00:01:06.338468009], VIM, 235, vim_app, 243, Critical, vim_app.c, vimapp_HBMsgHandler 346,  VIP Rebooted -- Missing Messages
Jan  1 00:01:07 vim_app: [000.00:01:07.326028009], VIM, 235, vim_app, 235, Warn, IUC.c, IUC_SPI_PopTxMessage 1691, Pop message from TX queue. ID 0030, 00 B
Jan  1 00:01:16 reflash_app: [000.00:01:16.000151677], REFLASH, 236, reflash_app, 236, Info, reflash_app.c, reflash_app_Update 2961, Progress: 99%
Jan  1 00:01:17 vcm: [000.00:01:17.032751345], VCM, 299, vcm, 299, Error, vcm_csched.c, vcmcsched_HandleCommTimerExpiry 1030, No response from VIP! assuming its stuck...
Jan  1 00:01:17 reflash_app: [000.00:01:17.034414011], REFLASH, 236, reflash_app, 286, Error, reflash_common.c, REFLASH_ExecuteCommand 625, Failed to execute "/tmp/vcm --write-image /tmp/image-vip_appvfbl.mot", exit code = 1!
Jan  1 00:01:17 reflash_app: [000.00:01:17.035123678], REFLASH, 236, reflash_app, 286, Error, reflash_ua.c, reflash_ua_ThreadBeginUpdate 1603, Board reflash failed (REFLASH_Cannot_Perform)
Jan  1 00:01:17 reflash_app: [000.00:01:17.035475678], REFLASH, 236, reflash_app, 286, Info, reflash_ua.c, reflash_ua_ThreadBeginUpdate 1650, Exit from Begin Update thread
As far as I understand, the file "image-vip_appvfbl.mot" contains the firmware for this VIP, which is transmitted over the XMODEM protocol, but it was not transmitted completely.
And now its firmware is damaged, I see that renesas chips can be flashed via serial connection and the mot files can be extracted from the updates. The question is which mot file to use? or why it can not be programmed via reflash_app in the first place? Also it seems renesas chips can have serial bootloader as well.
I have this problem too. Did someone can resolved it?
Thank...
 

· Registered
Joined
·
1 Posts
I don't think you can invoke the rear camera from the infotainment system - at least I am not aware of it. That's an outside trigger signal and the infotainment system just reacts on it and super composes the AV signal with the opera browser.
I have a Mazda 3 2014 s grand touring. It has a backup cam. It seems that the backup cam is available to the infotainment system computer as /dev/video0 and the executable v4lcapture is responsible for rendering the backup cam image. When the car is in reverse gear and I do killall v4lcapture, the backup cam feed stops and I see a black screen. then when I do v4lcapture the feed shows up again.
Also, when the backup cam feed is showing, doing cat /dev/video0 often gives me timeout error and then exactly at that time, the backup cam feed gets killed.
When I put the car away from reverse gear, the device /dev/video0 does not disappear and it cat /dev/video0 behaves similarly. This gives me hope that the backup cam is still powered on when the car is not in reverse gear.
I tried to take a picture from the camera using gstreamer but failed:


/dev # gst-launch mfw_v4lsrc device=/dev/video0 num-buffers=1 ! filesink location=/tmp/test.jpg
MFW_GST_V4LSRC_PLUGIN 3.0.5 build on Jun 10 2015 16:30:09.
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
Setting pipeline to NULL ...
Freeing pipeline ...

 

· Registered
Joined
·
7 Posts
I have a Mazda 3 2014 s grand touring. It has a backup cam. It seems that the backup cam is available to the infotainment system computer as /dev/video0 and the executable v4lcapture is responsible for rendering the backup cam image. When the car is in reverse gear and I do killall v4lcapture, the backup cam feed stops and I see a black screen. then when I do v4lcapture the feed shows up again.
Also, when the backup cam feed is showing, doing cat /dev/video0 often gives me timeout error and then exactly at that time, the backup cam feed gets killed.
When I put the car away from reverse gear, the device /dev/video0 does not disappear and it cat /dev/video0 behaves similarly. This gives me hope that the backup cam is still powered on when the car is not in reverse gear.
I tried to take a picture from the camera using gstreamer but failed:


/dev # gst-launch mfw_v4lsrc device=/dev/video0 num-buffers=1 ! filesink location=/tmp/test.jpg
MFW_GST_V4LSRC_PLUGIN 3.0.5 build on Jun 10 2015 16:30:09.
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
Setting pipeline to NULL ...
Freeing pipeline ...

I've dreamed of using the SD card slot in conjuction with the backup camera as a rear Dashcam. It would be more than enough to identify liability. You don't require a 4K telephoto lens for that.

That plus access to the CMU to enable tweaks like touch with Android Auto, and I would be in heaven.

Mazda (among other manufacturers) need to recognize the value of allowing user innovation.
 

· Registered
Joined
·
15 Posts
Hi, everybody.

I got a log from the console that says:

Code:
Jan  1 00:01:02 vim_app: [000.00:01:02.326027677], VIM, 235, vim_app, 235, Warn, IUC.c, IUC_SPI_PopTxMessage 1691, Pop message from TX queue. ID 0030, 00 B
Jan  1 00:01:06 reflash_app: [000.00:01:06.000153344], REFLASH, 236, reflash_app, 236, Info, reflash_app.c, reflash_app_Update 2961, Progress: 99%
Jan  1 00:01:06 vim_app: [000.00:01:06.338468009], VIM, 235, vim_app, 243, Critical, vim_app.c, vimapp_HBMsgHandler 346,  VIP Rebooted -- Missing Messages
Jan  1 00:01:07 vim_app: [000.00:01:07.326028009], VIM, 235, vim_app, 235, Warn, IUC.c, IUC_SPI_PopTxMessage 1691, Pop message from TX queue. ID 0030, 00 B
Jan  1 00:01:16 reflash_app: [000.00:01:16.000151677], REFLASH, 236, reflash_app, 236, Info, reflash_app.c, reflash_app_Update 2961, Progress: 99%
Jan  1 00:01:17 vcm: [000.00:01:17.032751345], VCM, 299, vcm, 299, Error, vcm_csched.c, vcmcsched_HandleCommTimerExpiry 1030, No response from VIP! assuming its stuck...
Jan  1 00:01:17 reflash_app: [000.00:01:17.034414011], REFLASH, 236, reflash_app, 286, Error, reflash_common.c, REFLASH_ExecuteCommand 625, Failed to execute "/tmp/vcm --write-image /tmp/image-vip_appvfbl.mot", exit code = 1!
Jan  1 00:01:17 reflash_app: [000.00:01:17.035123678], REFLASH, 236, reflash_app, 286, Error, reflash_ua.c, reflash_ua_ThreadBeginUpdate 1603, Board reflash failed (REFLASH_Cannot_Perform)
Jan  1 00:01:17 reflash_app: [000.00:01:17.035475678], REFLASH, 236, reflash_app, 286, Info, reflash_ua.c, reflash_ua_ThreadBeginUpdate 1650, Exit from Begin Update thread
As far as I understand, the file "image-vip_appvfbl.mot" contains the firmware for this VIP, which is transmitted over the XMODEM protocol, but it was not transmitted completely.
And now its firmware is damaged, I see that renesas chips can be flashed via serial connection and the mot files can be extracted from the updates. The question is which mot file to use? or why it can not be programmed via reflash_app in the first place? Also it seems renesas chips can have serial bootloader as well.
Huh, I haven't ran into that with all my playing around with the CMU. Is yours having an issue, or are you just trying to update it?
I haven't managed to trace out if the VIP has it's serial pins broken out, or just connected to the CMUs main processor.
I was trying to work out some of the pinouts/GPIO pinning on my documentation project mazda-cmu-documentation/platform_data.md at gh-pages · silverchris/mazda-cmu-documentation
 

· Registered
Joined
·
15 Posts
I have a Mazda 3 2014 s grand touring. It has a backup cam. It seems that the backup cam is available to the infotainment system computer as /dev/video0 and the executable v4lcapture is responsible for rendering the backup cam image. When the car is in reverse gear and I do killall v4lcapture, the backup cam feed stops and I see a black screen. then when I do v4lcapture the feed shows up again.
Also, when the backup cam feed is showing, doing cat /dev/video0 often gives me timeout error and then exactly at that time, the backup cam feed gets killed.
When I put the car away from reverse gear, the device /dev/video0 does not disappear and it cat /dev/video0 behaves similarly. This gives me hope that the backup cam is still powered on when the car is not in reverse gear.
I tried to take a picture from the camera using gstreamer but failed:


/dev # gst-launch mfw_v4lsrc device=/dev/video0 num-buffers=1 ! filesink location=/tmp/test.jpg
MFW_GST_V4LSRC_PLUGIN 3.0.5 build on Jun 10 2015 16:30:09.
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
Setting pipeline to NULL ...
Freeing pipeline ...

As far as I can tell, the CMU has only one video input, and it can switch it between 3 different external signals. Backup Camera/TV/Ipod Video.
The last two are not implemented/used in north america, but the video switching logic still exists.

It may be possible to switch to the camera without the car in reverse, but I haven't tested that, and I am not sure if it is electrically powered up.
I don't think that v4l likes having two things reading from video0 at the same time, so that might be causing an issue
 

· Registered
Joined
·
314 Posts
CMU can have up to 3 independent composite video inputs, depending on model and region, usually mfr. don't add these components, resistors, diodes, op amps if not used, so sending software codes isn't enough it's necessary to restore electronic components.
1A, 1B --- backup camera/ 360 view module
1G, 1H --- TV/DVD Japan market
1K, 1L --- IPOD VIDEO also used in Japan with converter as HDMI input.

Rectangle Slope Font Parallel Pattern


Colorfulness Rectangle Slope Font Line
 
6501 - 6520 of 6524 Posts
Top