2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

The Infotainment Project

3692459 Views 6544 Replies 1061 Participants Last post by  luyenok
MOD EDIT 8/12/15:





So, the Infotainment system is great, but it has me thinking how much greater it could be. There's so much potential wasted right now, and I would like to untap some of that.

The original post: http://mazda3revolution.com/forums/...-infotainment-system-software-components.html.
This got me thinking. This is obviously a linux-based OS running on an ARM chip. This was seen on this post as well: http://mazda3revolution.com/forums/...-accessing-infotainment-diagnostics-menu.html

I'm a software engineer, but don't have any experience dealing with low-level linux based systems. I would love to be able to either install custom, modified linux operating systems in the car or just be able to alter parts of the system to enable hidden or disabled parts of the system.

For instance, every european market has the ability to buy connected services (live traffic, weather, etc), and the Japanese market even can play DVD's and watch live TV!

This may at least give us the ability to upgrade our own systems without visiting the dealer, or use other applications through our phones such as Waze.

What I think may help here is getting the update code dump. This would be solved easiest if someone knows a dealer that can get the update software on a USB stick. If someone could upload that somewhere, we could then start analyzing the update procedure and the software and hopefully fine some way to hijack onto that process.
See less See more
  • Like
Reactions: 5
1 - 6 of 6545 Posts
can somebody help,i've installed the aio ver 1.50,and than somehow the application menu is not acceseable and than the usb port somehow is not work,because when i tried to uninstall the tweaks my usb did not read by the car

thanks for the help
does anyone remember or have and idea how to fix a non reponsive USB port? both of them dont respond. i just upgraded to V59 and was testing some things out. I thought i reenabled wifi and its not there. didnt run the ssh again yet and i'm kinda stuck. any ideas?
i have the same problem... after install AIO, my Apps and setting are not accessible, when i clicked it my screen freeze, USB is not repsonsive
Obviously, you can't use either a USB stick with a script nor an USB to Ethernet adapter.
So, you will need SSH access to CMU over wifi, or you have to solder a cable on CMU serial pins like id7 has done
hi do you have a a link that explain step by step to do SSH..?
i have the same problem... after install AIO, my Apps and setting are not accessible, when i clicked it my screen freeze, USB is not repsonsive
Actually, I just kept trying mine over and over and eventually it worked. I think it's because I was also messing around with a bunch of images and the system doesn't have that much memory. :/
I'll keep trying.... i tried to reinstall the framework, but the usb is not accessible....
after several trial and got nothing, any idea? its better in bootloop, because i just bring my car to dealer... right now some custom tweak applied to my MZD connect, so they will aware of customization which cause invalid warranty....
A German user did the same and he had to go to the dealer. The result I don't know.
the problem is my mzd connect not in bootloop, i can enter the main menu but unable to choose... and some of the tweak are applied, i.e blue theme, so they will aware of it... i just want to make it bootloop... the wifi is active, but cant ping, besides from what i read in this forum the 513 FW has unknow password or username....
Hi guys, i got my wifi enabled, and i can see johnson control when i did ip scan... but i cant ping to those devices nor the SSH.... any idea???
1 - 6 of 6545 Posts