2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
238 Posts
Discussion Starter #1
Hello everyone. Maybe someone has some answers for me. when my car is cold, it sputters and blows alot of black smoke. As it warms up, runs great. Any ideas? Plugs? Tuning? Turbo?
 

·
Registered
Joined
·
238 Posts
Discussion Starter #2
just spoke with tuner, he said it is most likely the FP. Logged the fuel pressure. Guess its time for a CPE pump. KMD internals not working so good:(
 

·
Street Unit - Ninja Killa
Joined
·
507 Posts
I saw you flaying last night and some black smoke came out after a shift as well.
 

·
Registered
Joined
·
238 Posts
Discussion Starter #4
just ordered the CPE fuel pump Should fix the issue. Hope it gets here when i get the car back from the body shop:) Happy New year.
 

·
Street Unit - Ninja Killa
Joined
·
507 Posts
Happy new year to you as well. Drive Safe.
 

·
Registered
Joined
·
596 Posts
just spoke with tuner, he said it is most likely the FP. Logged the fuel pressure. Guess its time for a CPE pump. KMD internals not working so good:(
No doubt the CPE pump will help at the high end (high pressure requirements) during warm up I don't know why this would be an issue. The KMD internals have a good rep so unless you have some logs that show this is an issue, I might look somewhere else.

At Cobb's suggestion, I have plugged my vent on my BPV/BOV so that I am only on bypass. After a discussion I understand the issue with allowing air out of the system. The comment that you are getting black smoke during a shift is interesting as this would be the same time in which you are blowing to atmosphere.

I am also in a learning mode with these cars but the above is what I have come to understand to this point in time.

Z
 

·
Registered
Joined
·
238 Posts
Discussion Starter #7
thnx Z. Explain more about what you did with your BOV, i have the forge on mine:)
 

·
Registered
Joined
·
596 Posts
thnx Z. Explain more about what you did with your BOV, i have the forge on mine:)
I have a Turbosmart DUAL PORT, therefore I was able to put the plug in the vent port thus everything goes to recycle. After what mod did the smoke start, quick list please.

Z
 

·
Registered
Joined
·
238 Posts
Discussion Starter #9
i have not done any new mods to car, this started about 3 weeks ago. Still waiting to hear from tuner, he is in mexcio, so might take a few days.
 

·
Registered
Joined
·
90 Posts
That doesn't sound good...
Did your tuner adjust your tune to account for the BOV?
If the car is still dumping fuel at shifts to account for the BPV, you would have a lot of extra fuel in there at shifts, and could be causing that smoke.
The tune should cut fuel to the injectors at shifts if you want to run a BOV.
 

·
Registered
Joined
·
238 Posts
Discussion Starter #11
car was running fine till about 3 weeks ago, no changes have been made to car.
 

·
Registered
Joined
·
238 Posts
Discussion Starter #12
really weird, just took the car out after sitting for over a day, no sputter or black smoke. Now i am confused:)
 

·
Registered
Joined
·
238 Posts
Discussion Starter #13
car is running great now, is it possible it had some bad gas? Or, maybe it did not like the cold air we have had here in SF. Still waiting to hear about the logs from tuner:)
 

·
Registered
Joined
·
596 Posts
I am going with magic

Z
 
1 - 14 of 14 Posts
Top