2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 4 of 4 Posts

·
Car Fanatic
Joined
·
35 Posts
Discussion Starter #1
Hey guys, can anyone help shed some light on my issues with my rear rotors? My car is a 2010 with only 16,500km on it and my rear rotors look like ass. They never did in the summer it seems only once winter hit they started to look like this, both the right and left sides.










The bronze looking stuff is the normal rust you see from sitting overnight or whatever, and will go away after driving for a bit, it is the other bad chunky looking stuff taht doesn;t seem to go away, which I find odd because the pads should everntually wear it off? I mean I engine brake as much as possible but still, you wouldnt think they would look like that.. Any help?
 

·
Peanutbutter Jelly!!!
Joined
·
361 Posts
Maybe your pads in the rear and not fully contacting the rotor when braking? I've never noticed that on mine. Any time it rains down here or is even foggy the rotors (all 4) get a coat of light rust on them but braking a few times removes it except where the pads don't touch which is normal but braking and having tracks around it like that... imo... is not normal.
 

·
Silver Demon
Joined
·
837 Posts
Mine look the same...I believe it's the pads...when it's time to change them, get some quality ones.
 

·
Car Fanatic
Joined
·
35 Posts
Discussion Starter #4
Yeah thanks guys, as I said, it makes no noises and there are no braking issues, they just dont look the best. A member on the other mazda forum said that they look glazed and to try braking hard for a couple weeks and I have done it on and off (hard trying not to get rear ended going from 60 to 30) and I do think there is a difference in them, hopefully they will wear off. Let me know if you get any changes.
 
1 - 4 of 4 Posts
Top