2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 24 Posts

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #1 (Edited)
2012 mazda 3 five door, skyactiv, 1500miles
Well two days in a row now while making a low speed turn (less than 10mph) the power steering quit working.

The first time it recovered after the turn was completed.
The second time was today while making a "U" turn today. The car had to be stopped, turned off and restarted. Even after the restart the car continued to have no power steering.
I stopped at my local Mazda and they couldn't help me unless the issue was present by that time it started working again. They weren't sure if the ECU would record a snapshot of the issue when it happend. I said there was no CEL just the power steering light came on and I lost all power steering.
I will continue driving it till it fails completely and have the car towed back to the dealer or it happens so much so that it is a safety issue.
 

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #3
they offered to do just that, but they would have to clear it with mazda and get their approval for a loner. I asked they proceed and ask, but the service tech said mazda wouldn't give me a loner unless they could figure out what was wrong first. Once figured out, if the replacement part is not able to be sourced locally only then would they ok a loner.
because it has only happened twice and it was random they wouldn't want to keep a working car in "hopes" it would happen again
 

·
Registered
Joined
·
1,131 Posts
Wow that's weird. No issues so far with mine. Almost up to 4000 miles.
 

·
On that college budget
Joined
·
5,278 Posts
ECU glitch? Electrical problem? Might just be random or it might be just the start of many more problems lol. Are you locking the steering wheel hard?
 

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #8 (Edited)
Happened again this morning. Making a left had turn from a stop light. Only dropped out for less than one second. Not even enough for the light to come on.
Here I thought it wouldn't happen again
Car had 2025miles on it
 

·
Registered
Joined
·
336 Posts
if you have time stop by and have them take a road test with you to see if u can duplicate it. advise on bringing a scan tool and checking voltages when making k turns.

i had an issue back when the vehicle was new when it was winter. did if for the first season about 4 times then it stopped never to happen again. never even had a chance to check it before the light was out.
 

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #11
Had the power steering drop out again yesterday for a split second. Was making a U-turn and as I was half way threw it, it dropped out till I finished the turn.
so almost 7months and not one issue. LOL Got to love cars.
 

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #12
well the car is at the dealer.
On my way this morning the steering dropped out three times in less than 1 mile. Then the traction control light came on. I stopped the car shut it off and restarted it.
Drove a bit more and on the first slow speed turn on to a side street the steering dropped out again.
Parked the car and in the evening the drive over to the dealership the steering was just fine, no issue at all.
 

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #14
The dealer called me and told me they figured out the issue. "The headlights are spliced into the power steering circuit" I said no they are not. He said the tech "unspliced" the connection and the power steering worked fine. I said nothing is spliced. It is possible the ground is shared. I asked if he thinks the ballast ground is causing a resistance in the line. He hesitated and said that is the issue. I said ok can you email me a photo of the connection in question. He does and it is a photo of the bulb connections. I call him back and say I'm confused you told me it is a ground wire issue you sent me a photo of the bulb connection. He said he wiggled that connection(bulb) and the power steering worked again. I said so it isn't a ground. He said he looked over the install and said it was a very nice install and just thinks it is bad connection. I didn't tell him I did the install I also went threw the wiring connections to prove my point that I don't think that is the issue. He still thinks it is the headlights. I said ok what is the charge for guessing at the issue? He said no charge.
I had a feeling they would blame something not even remotely connected to it. I explained how the lights are wired and he then agreed that it does seem very odd but the connections will have to be fixed before they will even call mazda about the issue.
I'll wire in another relay harness to help with the load on the car and move the ground wires to their own bolt so they are not sharing a connection.
I have ordered h1 halogen bulbs to replace the hids to use as a test.
They are full of crap and till I can prove it they will point fingers at things that are not remotely connected to it.
 

·
DIY PRO
Joined
·
1,036 Posts
Discussion Starter #15
well I teared in to the car tonight.
I think I found the issue. Mazda failed to tighten a stock ground wire fully. In doing so it most likely caused the issue.
I'll report back if the issue is resolved.
 

·
Registered
Joined
·
317 Posts
What dealership do you go to? I want to avoid this dealer lol. Glad you likely found the issue.....

I have concerns about Tom Masano's family of dealerships being of any help here in Reading in the event that i have any issues.
 

·
Zoom Zoom
Joined
·
5 Posts
Hi
I have a 2011 Mazda 3 2.0 engine. My power steering is loud and it sounds like a belt would be loose. I explained this to the tech at the dealership and he told me that is normal with power steering and just turn up your radio. Do you think that is normal I had belts checked nothing is lose. it does it all the time and it just screeches when I stay at the same speed then when I increase speed it stops then continues. It is embarressing I guess more than anything.
Today weird thing happened I went on highway and the car was shaking when I approached 45 mph. Its never done this ever I was so scared I backed off then went again up to 55 to see if it would continue and it did. I let the car warm up plenty this morning before going out. I didnt notice it when I came home an hour later but what does this mean??
Also, what oil to use ? I couldnt find 0w-20 book said then get 5w-20 and if store doesnt have that get 5w-30 I dont want to add oil if its not the right kind. Oil changes are $90 at dealership and its 45 min from my home.
Still love my mazda has around 16,000miles that is since July 2011 when I bought it.
 
1 - 20 of 24 Posts
Top