2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Pep boys replaced the neutral safety switch and shift cable on my Mazda 3 2008 sedan after their service advisor damaged it ( I never signed the paperwork to have him even touch the car and he shouldn't have moved it at all to begin with)Anyway I don’t feel they have put it back in the working order to what it was before they screwed it up. The car still will not start in park, it has to be put into Neutral for it to start and now the green LED/light does not light up at all. Just wondering what others think might be the root cause issue of this problem. Thanks in advanced. :surprise:
 

·
Registered
Joined
·
301 Posts
I agree. Ultimately you need to get them to fix the problem.

The transmission selector switch needs to be in a certain position to start the car. The tranny might be in park without the shift lever being in park. Something this can be due to the connection of the cable to the selector switch (or selector lever, whatever it is called). The connection is a weak plastic ball joint with a dumb clip to hold it in place. This broke on my daughter's car and I modified it so that it wouldn't have a problem again. Her car was completely unable to start because the shift lever couldn't move the tranny selector switch enough to truly be in the Park position.

Sorry that I don't have picture of my fix. Maybe next time I do an oil change for her I'll take a picture.
 
1 - 4 of 4 Posts
Top