2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Guys. I know theirs a few posts scattered around but can anyone help?

I have a mazda 3 TS2 11 plate I've got the fault code P0171 I've changed the MAF sensor but it still keeps coming back on after around 30 miles. Is got and unsteady idle but twice the engine has cut out ( well cut out once) and then I came back to the car and when I turned it over it just cuts straight out. I've had it at a garage and they don't understand it as next bday they went back to it and it started and worked fine and the fault didn't come up. So they've said nothing to diagnosed as no fault still their. Help please

Thanks in advance David
 

·
Registered
Joined
·
486 Posts
i had the same code come up a while ago. I changed a new Map sensor and it still came up. Clean the throttle body and nothing. I had a Corksport SRI and i decided to change back to stock air box and the code never came back ever
 

·
Banned
Joined
·
842 Posts
You need a Diagnostic Scanner that can read the monitors (check them for status) as well as normal DTC's. Next reinstall the old MAF sensor and clear all DTC(s) run a cycle and recheck DTC(s). It is advisable to not randomly replace electrical parts before confirming that they are in fact at fault. It is easy to create or worsen the condition or make it more difficult to diagnosis the problem. It is advisable When ever any electrical part is disconnected it should be inspected and cleaned with electrical parts cleaner before reconnecting.
If you look on line there is several things that need to be checked for your DTC. I looked generically (you did not state the year and engine size) for DTC service procedures in IdentiFix (paid service advisory program) and there is a little more to it then simply replacing a single sensor. You may find some related information generically on the internet to help you. Also All Data (another paid service) has information relating to this DTC and service recomend solutions. You may ask the service shop that had you Mazda to print out the info for you I am sure they have either or service I mentioned?
 

·
Super Moderator
Joined
·
6,385 Posts
Hi Guys. I know theirs a few posts scattered around but can anyone help?

I have a mazda 3 TS2 11 plate I've got the fault code P0171 I've changed the MAF sensor but it still keeps coming back on after around 30 miles. Is got and unsteady idle but twice the engine has cut out ( well cut out once) and then I came back to the car and when I turned it over it just cuts straight out. I've had it at a garage and they don't understand it as next bday they went back to it and it started and worked fine and the fault didn't come up. So they've said nothing to diagnosed as no fault still their. Help please

Thanks in advance David
What is a TS2 11 plate ?
Find a new place to take the car to. This code isn't hard to diagnose and its a pretty common complaint. A good service center should not have a problem with this. Just because the engine light isn't on doesn't mean there aren't codes still stored.
If the new MAF sensor didn't make a difference, the problem is most likely elsewhere. The upstream O2 sensor may have an intermittent fault thats triggering the code. It might be as simple as a loose or dirty connection thats not allowing the sensor to send the needed information to the ECU, or the sensor itself might be bad. Again, fairly common issue and not hard to find or fix. However, this alone probably won't cause the car to stop running.
If the engine is running a bit rough as you say there may be a vacuum leak somewhere, or there could also be an issue with fuel supply to the engine. Low fuel pressure, partially blocked fuel filter, dirty injectors etc can cause problems. If the car starts and runs at first then the problems start after driving a bit, the fuel pump might be failing. It might be ok cold, but the pump can get hot after running a while resulting in lowered or complete loss of fuel pressure. Eventually it just stops working altogether...been there, done that.....more than once.....:crying:
Once again, you need to take it to a competent shop that can figure it out.

i had the same code come up a while ago. I changed a new Map sensor and it still came up. Clean the throttle body and nothing. I had a Corksport SRI and i decided to change back to stock air box and the code never came back ever
SRIs can do this if they are either not designed right or they are not installed properly. All it takes is a change in air flow through the intake tube. For instance, a diameter change will alter the speed of the air flowing past the MAF sensor, which will cause the sensor to misread the amount of air being drawn in to the engine. This can lead to a lean condition if the engine is drawing more air than the MAF sensor is reporting.
 

·
Banned
Joined
·
842 Posts
:laugh2:...


The thing that I did not mentioned because I was more hoping somebody would do a better job of looking on the internet for an answer available FREE.

If someone came to me in the shop we would among a properly conducted OBDII port scan perform a smoke test!(you should talk with your service shop to perform one)


This DTC like all , either you get lucky and do it the lame way and replace a part or 2 and it is cured or you do it a properly through diagnostics procedures.

GOOD LUCK FINDING YOUR RESOLVE!
 

·
Banned
Joined
·
842 Posts
I wish on forums that you could give a 1/2 like for members responses. Most of some of things I read are good info what was found on the internet(not necessarily experienced based). I would have given a 1/2 like if it were an option on forums. :rockon 1:
 

·
Super Moderator
Joined
·
6,385 Posts
:laugh2:...


The thing that I did not mentioned because I was more hoping somebody would do a better job of looking on the internet for an answer available FREE.
You make many claims as to your experience and abilities. Perhaps if you were to direct your energy to actually make helpful posts and answer questions with direct helpful answers instead of making thinly veiled insults towards others?

I wish on forums that you could give a 1/2 like for members responses. Most of some of things I read are good info what was found on the internet(not necessarily experienced based). I would have given a 1/2 like if it were an option on forums. :rockon 1:
Your opinions concerning the abilities and skills of other members have no place on the forum. They are usually incorrect, and may appear insulting or derogatory to others, including the owners of the forum if you get my drift.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top