2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Noticed yesterday after getting the vehicle home (wouldn't you know it!) that the outside temp reading on the Nav screen was stuck at 78. Living here in PHX, AZ you can bet that we'd kill for an outdoor temp of 78 degrees so I know it was wrong. Drove it 3 times yesterday and once this morning, all showing a never changing 78, figured I had to take it back in and get it fixed/replaced. Then on the second ride today, looked at it and was actually glad to see it was reading 108! Not glad its 108 degrees here, but glad its working.

Any idea on why it was stuck and then suddenly starting working? Maybe it will get stuck again, I'll be sure and keep an eye on it.

Glenn
 

·
Registered
Joined
·
15 Posts
Yeah it happens to mine a lot, Not sure really what's causing it, the manual states it can be wrong if you drive to slow...
 

·
Registered
Joined
·
412 Posts
Yes, ours was stuck on 84 degrees when it was 100 outside the other day. My wife's Cadillac SRX used to get stuck too. Cadillac replaced her temp sensor, and then it worked normally.

Two possibilities here, one hardware and one software. There could some problem with the temp sensor itself.

The other possibility is the software. The temp you see displayed is not the actual raw reading from the temp sensor. All manufacturers process the raw data with other data to obtain a "corrected" reading. So if a lot of us are having problems, it could be that.

My first guess though, would be the temp sensor. If it keeps doing it, take it to the dealer. They can run diagnostic on it.
 
1 - 3 of 3 Posts
Top