2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi,
I got several updates because the MZD isn't very responsive. After my Mazda dealer installed Version 59.00.443 EU I recognized, that the Head Up Display do not show up the Directions (arrows..Streetnames...) anymore. I have to go the the Head Up display settings each time I started the car and switch off the Directions and turn them on again.
Thats really annoying.
Today the Mazda dealer installed 59.00.449 EU, unfortunately this didn't fix the issue.

Someone else here with the same issue and a solution?

Thanks in advance for any help,

Jazzer
 

·
Registered
Joined
·
2 Posts
I have the same problem and there is no way to fix it until they will update mzd connect.
Is there a way to send feedback about mzd connect to mazda?
 

·
Registered
Joined
·
22 Posts
Hi, do you remember what the CMU software version was originally installed in your cars, when bought?
There are some issues reported about 59.xxx installed on older than 2017 models due to lack of sensors, which are present in the newest ones.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Hi, do you remember what the CMU software version was originally installed in your cars, when bought?
Sorry, i can't remember which version was installed originally. But when I got the car, the MZD was very slow and I had to wait 3 Minutes before it responded. The HeadUp Directions were working and there was more options to choose (Lane assist, or only direction arrows...).

I will call my dealer. They have to inform Mazda, that there is still an issue...

I will let you know, when I got some feedback.

Cheers,

Jazzer
 

·
Registered
Joined
·
12 Posts
I have same problem 59.00.443 EU.
only using the reset option will let it work each time you are using the nav.
 

·
Registered
Joined
·
2 Posts
Hi, I have the same problem with the 59.00.443 4AN. The only way to fix that is disconnecting and then re-connecting everything the line guides in the head up display menu.
 

·
Registered
Joined
·
468 Posts
I only tried using the navi once this week, and so far the directions display on the HUD.
 

·
Registered
Joined
·
5 Posts
Hey guys,
I think I have found a workaround:
after the update to .449 I had the exact same issue - no guide on the HUD.
Off and On of the option in menu helped, but only for one ride.

What I did:
1. Start the car
2. Add some destination in Navi (no direction on the HUD so far)
3. Off and then On the option in Settings - directions appeared on the HUD
4. Stop the engine, lock the car
5. Open the car and start the engine - previous route should remain in Navi and direction signs should still be shown on the HUD
6. Cancel the route

From this point, directions appear every time I add new destination, even after restart.

Hope that helps....
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Hi fubarnet,

It works great if I stay in the car in step 4-5. If I leave the car in step 4 and enter the car in step 5 the option in the settings is "off" (I left it in "on" at step 3). I have to switch it on again.

Did you leave your car as well?

curious..
 

·
Registered
Joined
·
8 Posts
Discussion Starter #15
Did you try a day after? Is it working, or is the option always "off" like in my car?
I went through all your steps staying in the car. But after I left it ones, it "forgets" the last setting ("on").

I did not get a reply from MAZDA, yet.
 

·
Registered
Joined
·
5 Posts
I did this operation 4 days ago. And since then - I am using GPS every day and directions on HUD works from the start, without any manipulations at all.
When I switch direction in Settings to ON in the 3rd step - it never goes to OFF by itself in further steps.
Try to perform all the steps from the very beginning, but without locking the car.
Like so:
1. Start the car
2. Go to settings and make sure that directions on HUD are ON
3. Add some destination in Navi and drive along the route (make sure that no directions are shown on HUD) - in other words, try to reproduce the conditions of the bug
4. Go to setting and turn Off and then On the setting - directions should appeared on the HUD
5. Stop the engine, stay in the car for 30 sec
6. Start the engine and drive along the route - in my case, previous route remained in Navi and direction signs were still shown on the HUD
7. Cancel the route

After that exact sequence of actions - I have directions on HUD from the start for already 4th day...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #18
Hi fubarnet,

I performed a Factory Reset yesterday and followd your steps above exactly. Unfortunately, this morning I had no direction on the HUD.
When I went to settings they were switched on.

Thanks anyway,

Jazzer
 

·
Registered
Joined
·
2 Posts
@Jazzer, I'm not sure if the following works for you but it did for me when I lost the "Lane Guidance and Turn-By-Turn" on the Active Driving Display after updating to 59.00.443.

1. Cancel all routes in Navigation (if any) and disabled "Lane Guidance and Turn-By-Turn" on the Active Driving Display.
2. Drive your vehicle as usual and lock your vehicle once arrived at destination. Wait for 10 mins.
3. Start your vehicle and enable "Lane Guidance and Turn-By-Turn" on the Active Driving Display.
4. Select new route and check if "Lane Guidance and Turn-By-Turn" on the Active Driving Display is working.
5. Drive your vehicle until you reach destination and lock your vehicle once arrived at destination. Wait for 10 mins.
6. Start your vehicle, select new routes and verify if "Lane Guidance and Turn-By-Turn" on the Active Driving Display is still working.
7. Happy :)
 
1 - 19 of 19 Posts
Top