2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello I'm Paula. I have a 2004 Mazda 3 hatchback. I love my car, but its a pain in the ass lately. The passenger side wheel is making a god awful grinding kinda noise. Ive changed out just about everything and i still cant fix it.
Then today my passenger side window stops working.
Any advice would be amazing on what the issues could be.
 

Attachments

·
Registered
Joined
·
3,824 Posts
OK, first tell us what you changed out. Then is the noise all the time, at a certain speed or just under breaking. On the window first check the fuses. If they are OK then you will have to pull the door panel and check out the window motor to see if power is getting to the motor. If there is power replace the motor. If no power and the fuse is good then there is a wiring problem and gets more complicated.
P.S. Nice tats
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I've changed the struts tie rod ends sway links axles it's got new brakes brand new tires I've had the bearings checked and was told that it's not the bearings. It doesn't more so when you speed up. Emma window mysteriously started working again this morning
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
No, i finally took it to the shop to get looked at. Looks like ill be changing my tie rods again. Less then 2 yrs old and already bad again.
 

·
Registered
Joined
·
4 Posts
continuous grinding noise points me towards a wheel bearing/hub assembly. Tie rods would typically only cause a grinding noise when the alignment is way off causing scalloping of the tires.

I would make sure that the shop gives you back the old parts they took off, most of the parts you listed don't typically require a core return, so they can easily give you parts.

Other source of grinding is a bad brake pad grinding against the rotor, but you said they replaced that stuff. i would crawl under it and look for heavy gouging on either side of the rotors at all 4 corners (not sure if your model has drums on the rear or not).

I'm sure there's plenty i'm forgetting right now. Keep us updated....
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Sorry been gone a bit. Finally found whats wrong with my car. After taking it to 2 different shops. One told me it was my tie rods bad again. Fixed it got an alignment and guess what? Still didnt fix the noise. Second shop took my car tore it apart and we found whats wrong finally. Its the CV intermediate shaft. Getting the parts here Friday and finally getting it fixed.
 
1 - 11 of 11 Posts
Top