2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Hey guys so major problem with my 2010 mazdaspeed3

While driving my car electronics just keep restarting. Everytime I use something using electricity such as rolling down my windows or turning on my stereo, all the electronics in my car restart and reboot. While rebooting I even loose power steering. All my mods are listed in my sig. The only wiring I have tampered with is an DDM HID kit but not sure if that could be the issue. If anyone has any idea what could be causing this to happen i would appreciate the help :crybaby 1:
 

·
Registered
Joined
·
4,313 Posts
^Bingo. My friends moms Hyundai Veracruz was doing the same when her alternator was fried. Sorry for bad news :(
 

·
Registered
Joined
·
5,839 Posts
Sounds suspicious for an alternator to go bad that soon
 

·
Registered
Joined
·
63 Posts
Discussion Starter #6
Do I really have to demod everything or is just the hid kit and tune fine?


Sent from my Autoguide iPhone app
 

·
dutchabag
Joined
·
292 Posts
Need to check all you Electronic mods,check all you ground that you did in your mods.check battery ground,before you go to the dealer,if you have a autozone or advance auto or some were they can check charge and battery;the dealer might give you problems when they see electronics mods done,to fix it on warranty
 

·
MAAAAAD
Joined
·
2,140 Posts
I'd just remove anything related to electrical. Especially the tune as they will probably use that to void your warranty. I have a feeling its the HID kit.
 

·
Registered
Joined
·
383 Posts
My dealer did not care about my HIDs when they were troubleshooting failing tail light bulbs but that was not as major. I agree though. Just unhook them and put the regular bulbs back in. If it still happens, take it in.
 

·
MAAAAAD
Joined
·
2,140 Posts
My dealer did not care about my HIDs when they were troubleshooting failing tail light bulbs but that was not as major. I agree though. Just unhook them and put the regular bulbs back in. If it still happens, take it in.
yea mine didnt care either..but it's probably safer to just take it out. Doesn't take that long to take them out and put them back in anyways haha but those dealers...they'll blame anything little thing thats not factory as the cause. :argh 1:
 

·
Registered
Joined
·
383 Posts
Yeah mine blames anything they can on my air intake. I am either going to take it out or cancel my extended warranty and get my money back. No point in having it if they are not going to cover anything. lol
 

·
MAAAAAD
Joined
·
2,140 Posts
Yeah mine blames anything they can on my air intake. I am either going to take it out or cancel my extended warranty and get my money back. No point in having it if they are not going to cover anything. lol
hahah thats why i just take mine off before i go in for service.. even something simple as oil change cuz I don't want them b*tching about it when it has nothing to do with the rattle in the trunk hahaha
 

·
Registered
Joined
·
383 Posts
lol, yeah. My problem is what is next, are they going to not cover my shocks(which are all squeaking) because i have aftermarket wheels? lol
 

·
On that college budget
Joined
·
5,278 Posts
It is your alternator, same shit happened to my Mom's Veracruz as well and it only had like 18k.. lol.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #16
The issue seemed to stop. Really weird.... I will prolly still take it in to the dealer to get it checked out though
 
1 - 16 of 16 Posts
Top