2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I put on a short ram intake. and it threw a CEL code saying its running too lean. i put on the old box and it is still running to lean, same code. I'm pretty sure its my Maf sensor thats fucked. Can i clean the maf sensor some how? or do i HAVE too replace it ? instant responses via text would be very helpful thank you!

marcus -6308885978
 

·
Registered
Joined
·
1,767 Posts
Try MAF sensor cleaner, then check for any vacuum leaks. Also, clear the code (either with a reader or by disconnecting the battery like OrangeVirus stated).

Let us know what you find.
-Tyler
 

·
Registered
Joined
·
5,839 Posts
First before you spend money when you installed the SRI did you unplug the battery? It needs to reset the ECU otherwise if you dont unplug its going to run off the last amount of air flow
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
okay, even with the original box I'm still throwing a code. and yeah i left he battery unplugged overnight. i cleaned it today, and it was working great! great response and better gas mileage until about 45min of driving then what do u know. Im throwing a code again. Does anyone know where A vacuum leak could Possibly be at?
 

·
Registered
Joined
·
3,274 Posts
did you rehook up that line from the back of the valve cover to the accordian hose? also it could be your maf isn't sitting straight. these cars are VERY touchy about the mafs
 

·
On that college budget
Joined
·
5,278 Posts
What short RAM Intake did you buy? But, all these steps mentioned above should fix it.... if not you are doing it wrong.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
i had a spare HKS short ram intake from my 240 that had all the same hose attachments on the pipe as the ms3 so i threw it on there. it could be that the maf isn't level because its at like a 45 degree slant right now.
 

·
Registered
Joined
·
1,767 Posts
i had a spare HKS short ram intake from my 240 that had all the same hose attachments on the pipe as the ms3 so i threw it on there. it could be that the maf isn't level because its at like a 45 degree slant right now.
Is the sensor square inside the housing? Or is it slanted inside the housing at 45 degrees?

-Tyler
 

·
Registered
Joined
·
3,274 Posts
is the diameter even the same? the inner diameter must be the exact same as stock for your intake or you will throw a code.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #12
Is the sensor square inside the housing? Or is it slanted inside the housing at 45 degrees?

-Tyler
the sensor is sitting flat/level in the pipe. but instead of it being at a 90* angle the pipe has it turned at a 45* angle.


You'll need a breather for the hose, you can't just leave it open.
the hose is hooked up my hks pipe had a inlet for the hose.
 

·
Registered
Joined
·
3,274 Posts
the angle doesnt matter so much, it does, but doesn't. I had my maf completely sideways and it worked fine. even tried it upside down, it worked. the thing is the INNER diameter of the pipe that it is in. if it is not the exact same size as stock, you will get cel's and there is no way around it.
 
1 - 13 of 13 Posts
Top