2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all,

New member and new owner of a 2016 Mazda 3 Touring edition.

So my car did not come with a navigation system, so I went and bought an SD navigation card. It worked for about 2 weeks and now when I push the navigation button it says I don't have a navigation system. Is there something else I should have done besides the SD card?

Thanks
 

·
Registered
Joined
·
327 Posts
No, it's only the SD card.

Remove the card, clean the contacts, replace it and try that. If it doesn't work and you bought it from Mazda take it to them for replacement.

If it doesn't work and you bought it elsewhere, chances are it's a counterfeit - possibly a very low quality card and there may not be much you can do if the vendor won't refund or replace. You'd need to reach out to them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks Studum. I bought it off of ebay, so it maybe a cheap card.
I appreciate the quick reply
 

·
Registered
Joined
·
306 Posts
Thanks Studum. I bought it off of ebay, so it maybe a cheap card.
I appreciate the quick reply
insert the sdcard on your pc and try to copy all as they are on other sd card and try... there better way too use Mazda toolbox to backup the card and make update and then you can generate other reserve sdcard... ebay sdcard still working on tool box
 

·
Registered
Joined
·
5 Posts
Glad I just found this Site and this Thread too.....just bought a 2014 M3 s GT w Navigation....salesman said it worked....then went to demo it and was embarrassed because when he take the card in and out it would end up saying the car did not have Navigation. He said he'd fix it....I bought it....believed him....WARR expired....AS IS....did not get anything in writing [what a DUNCE]! Anyway, a day after I bought the car I went to the Dealership because the Salesman said He wanted me to come back so he could get the NAV working.....he was selling another car and sent me to their Service Dept......the Manager came out and took the SD Card in and out etc. and said they would have to have me bring it into their shop to be analyzed and figure out what is wrong with the NAV System.....I set up an appointment for the 6th....but told him or asked him if there would be a charge for this since I was told it's NAV System worked.....he said, did not know, maybe, maybe not, might be covered under WARR but it's a 2014....3 years are up.
Any more DIY ideas for me to try.....I wasted my Savings and then some making this deal....fear going into their Service Dept and being told Sorry, u bought it AS IS - NO WARR....will be $550 for a new NAV System.......BYE BYYE!

What is the Mazda Toolbox mentioned in previous post.....where can I get it ---will it possibly help me get this working. I read somewhere one fella said he disconnected his BATT for a couple of minutes ....made everything reset.....used that on my Hyundai before.

TKS 4 any help....Michael:smile2:
 
1 - 5 of 5 Posts
Top