2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
Suddenly the turn-by-turn nav on my Mazda3 2017 stopped working. Firmware is on 59.00.502.

If i don't enter a destination, the arrow follows location, so GPS is working. it just doesn't do turn-by-turn. Instead it displays a cross hatch with the destination. (See image.)

How do I fix this? Mazda dealer was no help at all.

Note this thread about Nav system display on HUD. This is not my issue, as Nav isn't working on main display.

Also, frequently it takes forever for nav system to fully load. For example, can't enter a destination or even select "home" or adjust many settings. Is this at all normal?

Other problem: recently on a cold day, infotainment system would not shut off at all when I turned off ignition. Tried multiple times and finally got it to turn off (after driving car a while longer). Anyone see such a problem? What to do in a case like that? Obviously if I had to park and leave the car it would drain the battery.
 

Attachments

·
Registered
Joined
·
703 Posts
You could try setting MZD Connect to factory settings or do a hard reset - press mute+navigation+return at the same time for 10s. If the screen won't turn off then I would disconnect the main battery for a few minutes. Then see your dealer to fix the problem under warranty.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
thanks, sc489. hard reset (twice) did not work. How do you restore MZD Connect to factory settings? I see several separate reset options, one under AD-Display, one under Display (I think), another (all factory settings) under settings. One of those you mean? Or something else?
 

·
Registered
Joined
·
703 Posts
thanks, sc489. hard reset (twice) did not work. How do you restore MZD Connect to factory settings? I see several separate reset options, one under AD-Display, one under Display (I think), another (all factory settings) under settings. One of those you mean? Or something else?
I meant the last one you mentioned - but I've never had to do this.
 

·
Registered
Joined
·
90 Posts
Try removing the SD Nav card before you power up the car, switch the car on and select Navigation, when the car says nav not fitted you insert the card and it might do a fresh load from scratch.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
press that button
I don't have (or can't find) such a button. (See picture). Maybe you have an earlier firmware? Otherwise how do I get to that button?

Try removing the SD Nav card before you power up the car, switch the car on and select Navigation, when the car says nav not fitted you insert the card and it might do a fresh load from scratch.
No dice. :(

I meant the last one you mentioned - but I've never had to do this.
Do you (or anyone) know if I do reset to factory, do you also lose favorites (destinations, contacts)? how bout bluetooth pairings?

FYI, I made an appointment with dealer. They're very clueless. They couldn't even tell me the latest FW version # they have –*I asked if it was 59.000.504, and they had no idea. Just assured me they had whatever was the latest.
 

Attachments

·
Registered
Joined
·
1 Posts
I also find I have this problem with my 2016 Mazda 3 sport.
I sent this message to Mazda Hands free support:-
User Comments: I updated the maps, late 2019 and due to Coronavirus, I have not traveled anywhere requiring the use of the navigation system. Now that the lockdown is easing and I can once again drive some distance, I find that the heads -up is not displaying the "turn-by-turn, any longer. I have looked at the settings, but "navigation " is no longer an option in the AD-Disp settings. Can you please help, as this is inconvenient when I need to use the navigation; which isn't very often , as I have only traveled 6,000 miles from new.
This was their response:-
We kindly ask you to contact your Mazda dealer for more information.
Our service is not responsible for issue.
What a complete waste of time they are?
Useless, like the Dealers, only interested in taking more money off you, after I bought two brand new cars within 12 months.
Never again.
 

·
Registered
Joined
·
5 Posts
Suddenly the turn-by-turn nav on my Mazda3 2017 stopped working. Firmware is on 59.00.502.

If i don't enter a destination, the arrow follows location, so GPS is working. it just doesn't do turn-by-turn. Instead it displays a cross hatch with the destination. (See image.)

How do I fix this? Mazda dealer was no help at all.

Note this thread about Nav system display on HUD. This is not my issue, as Nav isn't working on main display.

Also, frequently it takes forever for nav system to fully load. For example, can't enter a destination or even select "home" or adjust many settings. Is this at all normal?

Other problem: recently on a cold day, infotainment system would not shut off at all when I turned off ignition. Tried multiple times and finally got it to turn off (after driving car a while longer). Anyone see such a problem? What to do in a case like that? Obviously if I had to park and leave the car it would drain the battery.
See if it's covered under a recall. There is a known issue with some years Mazda 3. Look at debstubs comments after spending $ for updates, and console replacement. Noticed some got a notification that infotainment center has a recall that was extended bc of ghost issues with infotainment, and some issues with film that gets caught behind the screen, and you cannot see it. Hope that helps.
 
1 - 9 of 9 Posts
Top