2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
I'll try to make this quick to the point I have a 05 Mazda 3 hatchback 2.3 AT 103K and slowly the car has been running more and more rough, rough idle hesitating and I have 8 yes 8 cel codes they are
P0138 O2 Sensor Circuit High Voltage Bank 1 Sensor 2

P0139 O2 Sensor Circuit Slow Response (Bank 1, Sensor 2)

P2177 general OBD-II diagnostic trouble code indicating a fault with the bank 1 too lean

P2187 System Too Lean at Idle (Bank 1) DTC

P0037 HO2S Heater Control Circuit Low (Bank 1, Sensor 2)

The code reader has p0037/p0138 and p0139 all coming up twice

Basically all the codes are about the O2 sensor bank 1 sensor 2 which part of me is relived that all those codes and most are telling me that it's one part that's bad, Has anyone had anything like this before multiple codes for a o2 sensor? I'm planning on replacing my motor mounts tomorrow and cleaning out my throttle body so while I have it up in the air I want to check for exposed wires or something.

Also don't know if this might have something to do with it but I think I might need a new passenger junction box my horn,turn signals, headlights and dash lights all flicker and have problems unless I press my horn and hold it in then everything works fine I've read post on here and other sites where people have had a issue like that and it was the pjb can I just find a used one same year and model and have the dealership program it? Sorry if that felt like alot any help is appreciated
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
PLEASE HELP POSSIBLE PJB PROBLEM

Hi guys I really need help with my electrical issue 05 Mazda 3 at 103k symptoms I have are no horn turn signals do not work unless I hold the horn button same with the blue backlight in cluster and dash lights are heat and AC control. Sometimes when I start the car everything will work fine except the horn but for maybe a few minutes then everything starts to flicker out including my low beams and I hear a clicking sound that matches up with the flickering on the passenger side so I'm sure it's the pjb passenger junction box, also my account does not blow cold just warm air, my brake light stays on most of the time too everything I'm gathering is the pjb can anyone please help with suggestions I can just order a pjb off eBay that matches mine but any help would be appreciated I'm looking to sell it but those r the only problems that's keeping me from selling it
 
1 - 4 of 4 Posts
Top