2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2007 mazda speed3 and it misfires or sputters when I drive it. It would sputter alot when i would start it up before i changed the ignition coils and spark plugs. After I changed that it started up fine but it still would misfire when I drive it. Could anyone help me out?
 

·
Registered
Joined
·
90 Posts
I have a 2007 mazda speed3 and it misfires or sputters when I drive it. It would sputter alot when i would start it up before i changed the ignition coils and spark plugs. After I changed that it started up fine but it still would misfire when I drive it. Could anyone help me out?
What are all the OBD-II codes (including "pending") that you're getting?
 

·
Registered
Joined
·
2,016 Posts
this is sounding like another case of throwing parts at it and seeing what sticks. diagnose first, replace second. your wallet will thank you.

yes we absolutely need the codes. some diagnosis will be necessary to find the root cause. here's a list of possible causes off the top of my head, i'm sure i've missed a couple:
plugs, wires and coils. related wiring as well.
partially plugged or malfunctioning injector
failing fuel pump or other fuel parts such as a regulator
intake manifold leak
vacuum leaks
loss of compression due to head gasket failure, piston ring failure, or even cracked head/block
sensor faulty such as MAF, cam, crank, coolant sensors.
faulty ECU

bottom line is you're not giving us enough information to help. we need the codes, other symptoms if any, and how it misfires. is it at idle or under heavy load? more details is better.
 
1 - 3 of 3 Posts
Top