2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, new to the forum. Just got my Mazda 3 a few weeks ago and loving it. It is a 2011 I sport.

Anyway, I bought a 2 screen mid off eBay to upgrade from the 1 screen I had. I installed it into the car and disconnected the battery to reset. The screen works however it is only displaying in kilometers and the outside temperature does not display even though it did with the previous unit. Also the red screen that displayed radio information does not show anything now, juts the "hello" and "goodbye" when I start or stop the car. I was wondering if anyone had run into something like this before.

Thanks
 

·
Celest Zoom-Zoom
Joined
·
4,919 Posts
I'm a little confused. You say you had the temperature reading working before you bought the unit. The temp gauge is with the mileage. And you have the radio display. So you had two screens before?? Do you have the info button on your steering wheel?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
When I got the car it just had the one long red screen that displayed the time, temperature, and radio information (song title etc). I bought a unit that has 2 screens , 1 monochrome and a smaller red screen and installed it into the car. The monochrome screen works but displays in kilometers not mpg and the temperature does not display in the upper left side of the screen like I have seen in pictures. The smaller red screen now does nothing but say hello ajd goodbye.

Sorry if I was unclear before. I hope this is easier to understand.
 

·
Celest Zoom-Zoom
Joined
·
4,919 Posts
Okay I gotcha. You were clear I didn't know the temp was displayed in the red screen. Do you have the info button on your wheel?
And I dont know exactly what may be wrong.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
No I don't have the info button on my steering wheel. I was wondering if that might be my problem but I would think the red display would still work for the radio. I might try disconnecting the battery again for longer to make sure it resets itself.
 

·
Celest Zoom-Zoom
Joined
·
4,919 Posts
The info button may prevent you from changing the kilos to miles. Reset it all again and see what happens.
 

·
Registered
Joined
·
633 Posts
You need the info button in order to access the mid screen features.

Pat.
 

·
Registered
Joined
·
5,636 Posts
A new MID isn't plug and play. You have to go to the dealership. They have a software program that will make it work correctly.

I had the same identical symptoms as your problem. My MID failed and the dealer installed a new one thinking it was PnP. Nope, just displayed Km and hello and goodbye. Had to wait a week for Mazda corporate to send the dealer the software to upload to the car.
 
  • Like
Reactions: swerv0428

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Thanks warlord. Did that get your temperature to display as well? I was hoping it would be plug and play cause there was a thread on here I had read of people installing the 2 screen mid into their cars but there was no mention of any software updates.
 

·
Registered
Joined
·
5,636 Posts
Once the dealership programmed it everything worked normally including temp and being able to set it to English instead of metric. This happened to me in late 09 so I'm sure your dealer has the software already. Mine happened when the 2nd gen first came out so the dealerships were still unsure at how everything worked on the 2nd gen cars. I'm trying to remember but when they replaced the white mid that was the only one that didn't read correctly. Temp read in Celsius and distance was in KM and couldn't be changed to english units. Red screen was still fine if I remember correctly.
 
  • Like
Reactions: color0

·
Registered
Joined
·
633 Posts
Once the dealership programmed it everything worked normally including temp and being able to set it to English instead of metric. This happened to me in late 09 so I'm sure your dealer has the software already. Mine happened when the 2nd gen first came out so the dealerships were still unsure at how everything worked on the 2nd gen cars. I'm trying to remember but when they replaced the white mid that was the only one that didn't read correctly. Temp read in Celsius and distance was in KM and couldn't be changed to english units. Red screen was still fine if I remember correctly.
I don't know about the US models but in My Canadian GT I can change the temperature and mileage displays in the mid with the info button, it's in the section of the MID where the maintenance display is.

Pat.
 

·
Registered
Joined
·
5,636 Posts
Because the new mid wasn't programmed the info button was inoperable. That's why he has to go to the dealer to get everthing talking to each other.
 

·
Registered
Joined
·
633 Posts
Because the new mid wasn't programmed the info button was inoperable. That's why he has to go to the dealer to get everthing talking to each other.
Okay now I get you. BTW why did you trade the 2011 speed so quickly did you have problems?

Pat.
 

·
Registered
Joined
·
5,636 Posts
Kind of yes and no. I had accident and the paint was a crappy match. I over powered the clutch on E85 and it was starting to slip and the engine was burning oil a little. The car had zero issues on it's own. It was me that created the problems. I figured before I had to throw money at the car I'd flip into a new one. Glad I did, the tech package is sweet. At this point I'd do Katskins before I did engine mods. The car is a fast daily driver now. I'll probably leave it that way.
 

·
Registered
Joined
·
633 Posts
Kind of yes and no. I had accident and the paint was a crappy match. I over powered the clutch on E85 and it was starting to slip and the engine was burning oil a little. The car had zero issues on it's own. It was me that created the problems. I figured before I had to throw money at the car I'd flip into a new one. Glad I did, the tech package is sweet. At this point I'd do Katskins before I did engine mods. The car is a fast daily driver now. I'll probably leave it that way.
Ah yes the Liquid silver paint is a bastard to match, I had to have a door replaced on mine when it was 3 weeks old due to some dick dunting it in a parking lot. The painter said the paint gave him fits matching it. He knows how particular I am about my car, and anything less than a perfect match would be unacceptable.BTW Liquid silver is Aluminum Metallic in Canada.

I love the Katzkins I installed in my car the leather is beautiful and soft. If you do go for katzkins for the 200 bucks difference get the all leather kit. They have 3 kits,base, Premium, and all leather.

Pat.
 
  • Like
Reactions: warlord

·
Registered
Joined
·
5,636 Posts
If I did get them this is what i would buy. Full black leather, red stitching and Barracuda (full body not just inserts) and Barracuda door panels. Wouldn't want to be slipping around in G-force turns. :shocked:
 

Attachments

·
Aspiring Mad Scientist
Joined
·
1,716 Posts
Once the dealership programmed it everything worked normally including temp and being able to set it to English instead of metric. This happened to me in late 09 so I'm sure your dealer has the software already. Mine happened when the 2nd gen first came out so the dealerships were still unsure at how everything worked on the 2nd gen cars. I'm trying to remember but when they replaced the white mid that was the only one that didn't read correctly. Temp read in Celsius and distance was in KM and couldn't be changed to english units. Red screen was still fine if I remember correctly.
Kind of seguing off, but does the MID still work if the headunit is unplugged? I would like to eventually take out my stereo system just because I never use it, but I'd really like to not disturb the other functions of the MID such as remaining range and real-time mpg estimates.
 

·
Registered
Joined
·
5,636 Posts
So you going to just leave a big hole in the dash? IDK if anyone has done that before and if the mid would still work. I don't see why not. The mid controls are on the right side of the steering wheel and the audio controls are on the left. They are probably independent of each other.
 

·
Registered
Joined
·
633 Posts
If I did get them this is what i would buy. Full black leather, red stitching and Barracuda (full body not just inserts) and Barracuda door panels. Wouldn't want to be slipping around in G-force turns. :shocked:
That's basically what I got but all black with silver stitching.

Pat.
 
  • Like
Reactions: warlord

·
Registered
Joined
·
6 Posts
I upgraded from a single screen to a factory gps on my 2010. I also upgraded to a gt steering wheel with all buttons. Everything was plug and play and everything works except navigation prompts.Im going to the dealership to see what they have to say. Any ideas?
 
1 - 20 of 21 Posts
Top