2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 20 of 126 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 · (Edited)
Hi,
I'm working on it for near 2 months, but at least i made it.
- Adding the support of FLAC. now the CMU can read FLAC files with the metadata.
- Alphabetic ordering of the track (by directory)

Here the different steps https://github.com/diorcety/mazda3/wiki/Media-patching
The dependencies can be tricky to install (radare 2) so, here the track ordering & FLAC support of libmc_user for 56.00.230A or 55.00.750B (sha256sum, 903C4D56CDFB1ECDF465E77C2222AECA213AFF3A7390C8A32BB8CBA8623B6102, same binary): link
This not the only binary needed, please look the wiki pages.
 

·
Registered
Joined
·
345 Posts
Help me to patch my libmc_user.so

Hi,
I'm working on it for near 2 months, but at least i made it.
- Adding the support of FLAC. now the CMU can read FLAC files with the metadata.
- Alphabetic ordering of the track (by directory)

Here the different steps https://github.com/diorcety/mazda3/wiki/Media-patching
The dependencies can be tricky to install (radare 2) so, here the track ordering & FLAC support of libmc_user for 56.00.230A or 55.00.750B (sha256sum, 903C4D56CDFB1ECDF465E77C2222AECA213AFF3A7390C8A32BB8CBA8623B6102, same binary): Free - Envoyez vos documents
This not the only binary needed, please look the wiki pages.
Your file don't work with my MZD, can you patch my libmc_user.so for me?
Here the link of file: https://mega.nz/#!1kEwmR4L!KdgEYSBVLAgxC7m29g6RvdTuPk6G6hRvsw8HExpTEBg

Thank you 10000 time!
 

·
Registered
Joined
·
345 Posts
Invalid link :)
Sory, my fault, because i install chrome mega plugin.
I fixed the link. Please help me to patch this file... Thank.
PS: Can you test in your car about copy multi .flac file to usb and then plug in car an play them with Media play on your car... in mine it stuck in loadding when copy multi flac file to usb, but with only one file flac it play with no problem.
Thank again!
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #7 · (Edited)

·
Registered
Joined
·
345 Posts
I'm currently using it, with multiple files; it works. I fixed an issue few times after posting this post which can matches the issue you have(https://github.com/diorcety/mazda3/commit/b97fd0e34bdc4b547992ee047dfac6b721854385). I don't know if i updated the compiled program link. here the patched file Free - Envoyez vos documents, i will check my car version this WE
Thank you, i will try the file you send to me!
PS: File you sent me is of Ver 56.00.230A or of the 56.00.100A
I ask you to help patch.

Can you patch this file for me, please!

Thank you so much!
 

·
Registered
Joined
·
184 Posts
Not to hijack this thread, but is there anyway to compile some USB LTE modem drivers for this system? I know there have been people able to compile using the correct toolchain. Just a bit beyond my knowledge.
 

·
Registered
Joined
·
16 Posts
Not to hijack this thread, but is there anyway to compile some USB LTE modem drivers for this system? I know there have been people able to compile using the correct toolchain. Just a bit beyond my knowledge.
Since it is easy to enable WIFI on the CMU and you can just use a LTE MIFI card if needed, I am not sure if it worths the effort to get the USB modem working.
 

·
Registered
Joined
·
184 Posts
Since it is easy to enable WIFI on the CMU and you can just use a LTE MIFI card if needed, I am not sure if it worths the effort to get the USB modem working.
It would be worth the effort because it would automatically connect when the car is powered and would not require any user interaction. Batteries and rigging up a charging system for a mifi would not be easy and in hot and cold climates could be dangerous to leave in the car.
 
1 - 20 of 126 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top