2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
When accelerating, There is a ratling loise coming from the engine bay somewhere and i cant seem to pin point the exact location.

I thought it could be the belts maybe? or the pulleys?

I videoed a short clip of the engine running at idle but my post count is too low to post a youtube link

What do you guys think?
 

·
Mazda "E" Division
Joined
·
1,265 Posts
If it's the original belt tensioner.. I would recommend to replace it. Tapping noise is the fuel injectors.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
If it's the original belt tensioner.. I would recommend to replace it. Tapping noise is the fuel injectors.
it most likely is the original tensioner, second owner with 80,000kms on the clock

in the video, should the tensioner be moving back and forward like that?

hopefully not fuel injectors, it does seem to lag sometimes like it hasnt got gas but that doesnt happen often
 

·
Registered
Joined
·
37 Posts
Couldnt Figure out how to edit previous post

at about 0:31 you can hear the sound very clearly
Sounds like your belt is squealing. A worn belt can also cause a rattle on acceleration. Seen it many times on older Toyota Corolla 1ZZ-FE engines. Wasn't the tensioner, just worn belt. Not saying you shouldn't check the tensioner operation, but sounds like you need a belt between the rattle complaint and the squeaking I hear.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Sounds like your belt is squealing. A worn belt can also cause a rattle on acceleration. Seen it many times on older Toyota Corolla 1ZZ-FE engines. Wasn't the tensioner, just worn belt. Not saying you shouldn't check the tensioner operation, but sounds like you need a belt between the rattle complaint and the squeaking I hear.
Hey Thanks for the reply.

Ill order 2 new belts and put them on and see if that fixes the problem. will get back to you
 

·
Mazda "E" Division
Joined
·
1,265 Posts
it most likely is the original tensioner, second owner with 80,000kms on the clock

in the video, should the tensioner be moving back and forward like that?

hopefully not fuel injectors, it does seem to lag sometimes like it hasnt got gas but that doesnt happen often
Injectors are always noisy … normal operation
 
1 - 12 of 12 Posts
Top