2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello everyone

I'm having some issues with transferring files over serial to enable USB tweaks

I followed this tutorial "https://mazdatweaks.com/serial/"
I used Putty software
I used this serial adapter DSD TECH USB to TTL Serial Converter CP2102
I'm running CMU v. 70.00.100

But every time I run the code it doesn't work I get Permission denied.

If anyone could help I would appreciate it.

Thank you!
 

Attachments

·
Registered
Joined
·
49 Posts
Hello everyone

I'm having some issues with transferring files over serial to enable USB tweaks

I followed this tutorial "https://mazdatweaks.com/serial/"
I used Putty software
I used this serial adapter DSD TECH USB to TTL Serial Converter CP2102
I'm running CMU v. 70.00.100

But every time I run the code it doesn't work I get Permission denied.

If anyone could help I would appreciate it.

Thank you!
Did you put the script inside a folder named XX ?
 

·
Treveloper
Joined
·
534 Posts
Hello everyone

I'm having some issues with transferring files over serial to enable USB tweaks

I followed this tutorial "https://mazdatweaks.com/serial/"
I used Putty software
I used this serial adapter DSD TECH USB to TTL Serial Converter CP2102
I'm running CMU v. 70.00.100

But every time I run the code it doesn't work I get Permission denied.

If anyone could help I would appreciate it.

Thank you!
It looks like you have logged in successfully with "user" "jci" is that correct? so you can do something like
Code:
ls -l /tmp/mnt/data_persist/dev/bin
What does that output?
try this before running the copy code:
Code:
mkdir -p /tmp/mnt/data_persist/dev/bin
If that doesnt work then try
Code:
chmod -R 777 /tmp/mnt/data_persist/dev
if that doesn't work get back to me
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
It looks like you have logged in successfully with "user" "jci" is that correct? so you can do something like
Code:
ls -l /tmp/mnt/data_persist/dev/bin
What does that output?
try this before running the copy code:
Code:
mkdir -p /tmp/mnt/data_persist/dev/bin
If that doesnt work then try
Code:
chmod -R 777 /tmp/mnt/data_persist/dev
if that doesn't work get back to me
Yes I was able to log in, I took a screenshot of what happen if I didn't log in just to make sure,
I tried all your code and this is what came out
"ls -l /tmp/mnt/data_persist/dev/bin" = total 0
"mkdir -p /tmp/mnt/data_persist/dev/bin" = seems to do nothing
"chmod -R 777 /tmp/mnt/data_persist/dev" = Operation not permitted

so I don't what to do with that.
 

Attachments

·
Registered
Joined
·
49 Posts
Yes I have the XX folder at the root of my USB key format FAT32, I tried a 8gb and 16gb don't know if it matters.
I'm sure you got it right that's why Trez chime in when he saw something more than a missing folder and more with permissions creating those directories.
The truth is I don't think anyone have done the serial hack with version 70.00.100, maybe something was changed.
Don't worry, if is anyone who'll find the reason why that person is Trez

Did you install the official CP/AA? I mean the new HUB and cables.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
I'm sure you got it right that's why Trez chime in when he saw something more than a missing folder and more with permissions creating those directories.
The truth is I don't think anyone have done the serial hack with version 70.00.100, maybe something was changed.
Don't worry, if is anyone who'll find the reason why that person is Trez

Did you install the official CP/AA? I mean the new HUB and cables.
It reminds me I was on version 59.00.441 before, but I had a camera glitch so the way they fixed it at the dealer was to update my CMU to 70.00.100.
I didn't know they were going to do that or I would have said no :/ I don't know if the update have a impact on anything.

sadly no I don't have the new HUB
 

·
Registered
Joined
·
49 Posts
It reminds me I was on version 59.00.441 before, but I had a camera glitch so the way they fixed it at the dealer was to update my CMU to 70.00.100.
I didn't know they were going to do that or I would have said no :/ I don't know if the update have a impact on anything.

sadly no I don't have the new HUB
Warrior do you realize with version .441 you missed the chance to update and preserve USB access? wait a minute I checked your old posts and did you install AIO already or is this a different car? then
Why are you doing the serial hack for?

You may try login in with different user and pass, It you had AIO previously installed I think they added "cmu" "jci" or "jci" "jci" but I don't know it's related to SSH specifically.
let Trez answer this one or contact him [email protected]
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Warrior do you realize with version .441 you missed the chance to update and preserve USB access? wait a minute I checked your old posts and did you install AIO already or is this a different car? then
Why are you doing the serial hack for?

You may try login in with different user and pass, It you had AIO previously installed I think they added "cmu" "jci" or "jci" "jci" but I don't know it's related to SSH specifically.
let Trez answer this one or contact him [email protected]
I didn't know I could preserve the USB access before updating but I didn't know my mazda dealer was going to update me.

I had AIO install on .441 but before the car maintenance I uninstall everything in case they find something and lose my warranty,
so that's why I'm stuck with serial hack.
 

·
Registered
Joined
·
2 Posts
My mazda3's production date is 2018/5. I buy it at 2018/7. I have serial console access directory /tmp/mnt/data_persist/dev/bin but got permission denied. The directory seem been limit by root. So it's impossible to install autorun scripts and AIO tweak.

My firmware version is 59.00.540 4A N
 

·
Registered
Joined
·
5 Posts
I can log in to the CMD but when I run the command "cp -r /mnt/sd*/XX/* /mnt/data_persist/dev/bin/; chmod +x /mnt/data_persist/dev/bin/autorun; /mnt/data_persist/dev/bin/autorun", i am told it cannot find the file or the drive.

what to do to get acces to the USB drive.

any help please
 

·
Registered
Joined
·
1,655 Posts
Check if the usb stick is formatted FAT32 and has the XX folder on it. Do not use a MAC, but a Windows PC. If thats not the cause, try other usb sticks. Put the usb sticks in the cars usb slots for the serial access - do not put it in the PC/notebook/laptop.
 
1 - 14 of 14 Posts
Top