2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey everyone, I'm new to this forum. I have the 3 2.2 sport Nav skyactiv.
And I'm loving it so far.

I've noticed something though that only happens every so often.

Sometimes when I accerate hard when changing up a gear, there is a very slight lag in power when I engage the next gear. It only last a fraction of a second and then it pulls hard again but it is noticeable.

Would this be turbo lag or something else?
Anyone else noticed anything similar?

Thanks for any help/advise.
Rich.
 

·
Registered
Joined
·
563 Posts
Edited. Didn't realize OP was referring to turbo diesel model.
 
  • Like
Reactions: PuMoDi

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Sorry should have said that! It's the 2.2 diesel.

Anyone have any clue?
Might have to get it to a garage to have a look.
 

·
Registered
Joined
·
71 Posts
Ive read several times various turbo problems are casued by some sort of leaking air control pipes which open and close the wastegates on the turbos. Maybe worth a mention if you goto the dealers.

Ken
 

·
Registered
Joined
·
530 Posts
Possible traction control kicking in? The light might not come on but I have felt similar lag with the 2.5.
 

·
Registered
Joined
·
246 Posts
Could just be one of the plateaus on the ECU. If you shift at the wrong time it might be one of the spots where the computer lags the throttle on purpose to increase MPG. That would explain the "sometimes it happens, sometimes it doesnt" aspect. If thats the case then only an aftermarket tune will help.
 
1 - 9 of 9 Posts
Top