2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
So I decided to install LEDs throughout my 2014 Mazda3 HB, and I noticed that I ran into some issue; I hope someone can help me out here.

I have installed LEDs before on my previous 2014 Mazda3 HB without any issues, So I know about how you need to sometimes flip the little LED so it will work, But anyways, here are my issues.

I installed all the interior ones fine except for the one in the boot of the car, That one seems to be giving me some trouble. I tried installing one of the LEDs and I could tell that the light itself was coming on fine, but getting it to fit properly between those two little metal pieces was an issue. Upon trying to get it to fit out of nowhere the LED got really dim. I thought I broke the LED so I put back in the original bulb and noticed that it was dim now too. So what might be causing this issue?

My second problem I ran into was with installing the LED reverse lights. For some reason I can't get them to work at all. I have gotten Replacements and everything and still no luck. Again, Original bulbs work fine.

I thought maybe it could have something to do with the fuses?
And that brings me to another question; How come there are missing fusing in the fuse box? Should every slot be filled?

Any help advice would be greatly appreciated before I go and spend god knows what kind of time and money to have the dealership take a look at it.
 

·
Registered
Joined
·
5 Posts
... installed all the interior ones fine except for the one in the boot of the car, That one seems to be giving me some trouble. I tried installing one of the LEDs and I could tell that the light itself was coming on fine, but getting it to fit properly between those two little metal pieces was an issue. Upon trying to get it to fit out of nowhere the LED got really dim. I thought I broke the LED so I put back in the original bulb and noticed that it was dim now too. So what might be causing this issue?...
Maybe you have similar problem like this http://mazda3revolution.com/forums/...trunk-interior-light-problem.html#post1107274 .
 
1 - 3 of 3 Posts
Top