2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
so today i decided to install my tein lowering springs for my 2008 madaspeed3. i installed them and i also balanced my tires, as well an did an alignment. car drives fine normal driving below 3k rpm but once i start to gas it WOT, it seems to start shaking in the front a little. took the front wheels off and rebalanced them but shaking is still there. any clues as to what it might be? other ppl at my shop said its possibly the axle. ive been searching all day and cant find an exact answer, or even hints as to what it might be. all help is appreciated
 

·
Registered
Joined
·
1,074 Posts
so today i decided to install my tein lowering springs for my 2008 madaspeed3. i installed them and i also balanced my tires, as well an did an alignment. car drives fine normal driving below 3k rpm but once i start to gas it WOT, it seems to start shaking in the front a little. took the front wheels off and rebalanced them but shaking is still there. any clues as to what it might be? other ppl at my shop said its possibly the axle. ive been searching all day and cant find an exact answer, or even hints as to what it might be. all help is appreciated
if it's shaking while you are on the gas pedal and goes away when you let off then it's probably the axle, happened to me last year :/
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
if it's shaking while you are on the gas pedal and goes away when you let off then it's probably the axle, happened to me last year :/
yeah two guys at my job/shop said that its that. im going to check everything out this week just to double check, make sure sway bar end links are tight, maybe do a rotation and see if it differs, and check my alignment again. all checks out good then id say its for sure the axle lol. but thats bro
 

·
Registered
Joined
·
1,074 Posts
mine only shaked when im on the pedal going about 45mph+ it started out small but started to get real bad so i replaced the axle and everythings good meow
 

·
Registered
Joined
·
1,074 Posts
any specific brand to get? and should i replace both?
i went with an oem remanufactured axle, got it from online mazda parts. There isn't any aftermarkets for 2nd gen, 1st gen on the other hand is a different story, o'Reilly has them, not sure about the speeds tho
 

·
Registered
Joined
·
1,663 Posts
Check the end of the spring if its exactly sitting down on the strut case. Make sure before decompressing the spring compressor that there's no play between the spring and the strut assembly spring stopper

Sent from AutoGuide.com Free App
 
1 - 9 of 9 Posts
Top