2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 57 Posts

·
Registered
Joined
·
278 Posts
Discussion Starter #1
READ BEFORE YOU POST. I contacted Johnson Controls (who is the manufacture of the Mazda Connect system). If you are experiencing any issues such as: Bluetooth issues (audio static, popping, crackling), to system freezing, memory issues, crashing and tuner problems you need to either write or call Johnson controls and report your issues!

I spoke on behalf of all the threads posted and told them that there are HUNDREDS if not thousands of members in North America having the same issues and their reply was......


If other owners are having similar issues we would urge them to contact us by phone at 800-430-0153 Mon - Fri, 7am - 8pm CT or through our website at Mazda Connect.

PLEASE NOTE..... If you DO NOT have issues, great! do NOT post anything here. Again, it's for members who are experiencing issues, take the time and contact Johnson Controls and provide them with detailed issues your are experiencing. If we don't speak up our issues won't get resolved.

Here are the issues I reported to Johnson Controls

1) Bluetooth choppiness, popping, static, crackling (outdated bluetooth chip 2.1)
2) System will randomly re-boot while driving
3) System will not turn on at times (requires a re-start)
4) Blue screen
5) Unit freezes
6) Navigation voice doesn’t work (this is simply a hit and miss)
7) Unit looses all my settings
8 Cant select FM/AM/XM
9) Radio fades in and out
10) System struggles for the first 1 to 2 min after start up (as if the processor is struggling to keep up).

Cheers!
 

·
Registered
Joined
·
278 Posts
Discussion Starter #4
I know I said don't post...LOL, but has anyone been calling JC to give feedback? Complain? Yes, no?
 

·
Registered
Joined
·
574 Posts
Man, I hope people are taking the time to write in to JCI/Mazda about this.

#10 in seanc81's list really hit me hard today. It happened once a couple weeks after I got the car and it fixed itself after a minute or two. Today though, it was really rough. Audio kept cutting out, static-y, change in volume, even changing from BT to FM was a struggle or changing the station. I gave it 4-5 minutes and it just seemed like it was getting worse. I had to pull over and do a manual system reboot with the 3-buttons.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #10
For those experiencing issues (outlined above, dial the phone number and log a complaint and or write a letter). These issues will continue to drive everyone crazy unless we all speak up. Also, call Mazda Canada/USA and log a complaint as well. I've owned my car for 13 months and NOTHING has been corrected thus far.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #11
I second that! Imagine dealing with these issues for 13 months now. I've had.....7 software updates and still no change.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #12
I wrote another letter to JC. Here's what I said. I'll continue to keep you posted.

Hello,

I contacted your head office and spoke to a lady in December who, in return called the Service Manager where my car was repaired - as she wanted to know what parts were changed on my 2014 Mazda 3. I must say that I’m shocked that after owning this car for 14 months none of my issues have been corrected and the callback I was promised never happened. I provided you with my VIN number, what are the "next steps" with correcting these issues?

I strongly urge your organization to take some time and "Google Search" the following phrases and see how many “thousands” of Mazda owners are beyond frustrated with this system.

Mazda 3 infotainment issues
Mazda 3 infotainment boot issues
Mazda 3 infotainment bluetooth issues
Mazda 3 infotainment crashes
Mazda 3 infotainment terrible

I have 3 cars in my family, (other manufactures) with no Bluetooth Media issues, Reboots, Crashes, Slowness whatsoever.

Is there anyone else in your organization who I can talk to? At the end of the day I just want my car fixed!

I purchased my Mazda 3 (with the technology package) as I am a huge music buff. All my music is on the cloud and I stream everything. If I knew I would not be able to have “decent” sound with my Bose system I would've never purchased this car. What really puzzles me is that my 2012 Mazda 3 GT had no BT issues whatsoever.

Where do we go from here Johnson Controls?

Sean
 

·
Registered
Joined
·
137 Posts
As a UK user just wanted to note that Johnson sold the car electronics business to Visteon back in July last year. i have emailed them about the possibility of getting DAB on the units in the car and I am awaiting a reply.
Will keep you all informed
 

·
Registered
Joined
·
5 Posts
I had the following issues relatively frequently when I got my 2014 model.

1) Bluetooth choppiness, popping, static, crackling (outdated bluetooth chip 2.1)
2) System will randomly re-boot while driving
3) System will not turn on at times (requires a re-start)

I took it in to Mazda and they replaced the screen under warranty. I haven't had those issues since. Good chance that the hardware might have been slightly improved as well or from a 2015 model year part number. The screen looked a touch bit nicer than the one that came with my car.
 

·
Registered
Joined
·
2 Posts
In my 3 weeks of ownership, I have experienced,

1) Radio losing reception for few seconds ever s often.
2) Infotainment system not open the Apps/Music/Comm/Nav/Settings bubbles. I have to restart the car to get it to work again.
 

·
Registered
Joined
·
83 Posts
I had my ECU and "Tau" (infotainment control system) replaced on my 2014 Mazda 3i. Had it in over half a dozen times for infotainement issues. The primary problem for me was the voice recognition would not recognize commands. Plus there was a bogus radio station in my SiriusXM "favorites" that would could not be deleted. The dealer was as frustrated as I was. When they tried to replace it with a 2015 system they found the same issues. They spoke with Mazda tech in California numerous times as well as Johnson Controls and SiriusXM. Very few of the voice commands that are supposed to work do anything remotely close to what they are supposed to do. But it is functional since they replaced the whole system. If I want to give it an address for the Nav system, I have to say "Navigation", then "Address" and it will ask for the address. But I should be able to just say "Drive to (address)". The commands to play various radio/SiriusXM stations hardly ever work correctly so I have to just scan my "favorites". The car is coming up on its one year anniversary on 1/27/15. The dealer general manager said that my car problems were specifically discussed at a general manager's national meeting in the spring. Another oddity: after the bogus station was finally removed, when I hit the left arrow on the steering wheel it reappeared. But not using the right arrow. That one was driving the mechanic nuts. That seems okay since the system replacement. But the voice command problems remain.
 
1 - 20 of 57 Posts
Top