2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 221 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
Hi guys, not sure of this has happened to anyone. Everytime i drive my car and stop the infotainement system starts jumping around the menus and selects different radio stations or options and i cant control it.

When i start driving again then i am able to select the radio stations. I tried doing a factory reset and it stops doing it but a day later the same problems happens again. Just want to know if there are any solutions that i can do before i take it to dealer.

Thanks!!
 

·
Registered
Joined
·
306 Posts
Hi guys, not sure of this has happened to anyone. Everytime i drive my car and stop the infotainement system starts jumping around the menus and selects different radio stations or options and i cant control it.

When i start driving again then i am able to select the radio stations. I tried doing a factory reset and it stops doing it but a day later the same problems happens again. Just want to know if there are any solutions that i can do before i take it to dealer.

Thanks!!
its look more you have control knobs ( dirty , dust, or the cable connection had fault ) first while the car at off state.. try to play more time with the control knobs left right up down or clean.
 

·
Registered
Joined
·
181 Posts
Hi guys, not sure of this has happened to anyone. Everytime i drive my car and stop the infotainement system starts jumping around the menus and selects different radio stations or options and i cant control it.

When i start driving again then i am able to select the radio stations. I tried doing a factory reset and it stops doing it but a day later the same problems happens again. Just want to know if there are any solutions that i can do before i take it to dealer.

Thanks!!
Your knobs are all fine. Seems like you don't have the touchscreen tweak installed. Your touchscreen is faulty. Tapping sections randomly. This happens only when you stop because while driving, touchscreen is disabled.
 

·
Registered
Joined
·
306 Posts
Your knobs are all fine. Seems like you don't have the touchscreen tweak installed. Your touchscreen is faulty. Tapping sections randomly. This happens only when you stop because while driving, touchscreen is disabled.
LOL on which tweak you are talking about ??? he did factory reset and get fine, after drive ( shocking ) the fault remain back... are you inside his CMU to know if he did hack or not ???:smile2:
 

·
Registered
Joined
·
130 Posts
Discussion Starter #6
No hacks to the infotainment. its bone stock....i tried cleaning out the controls today. so far no issues yet but now the display doesnt fully deploy sometimes.......
 

·
Registered
Joined
·
306 Posts
No hacks to the infotainment. its bone stock....i tried cleaning out the controls today. so far no issues yet but now the display doesnt fully deploy sometimes.......
now you have cable connection issue ... reset all cable connection again and be sure all wire are pushed inside the socket to the end then your display remain on always
 

·
Registered
Joined
·
2 Posts
Hi guys, not sure of this has happened to anyone. Everytime i drive my car and stop the infotainement system starts jumping around the menus and selects different radio stations or options and i cant control it.

When i start driving again then i am able to select the radio stations. I tried doing a factory reset and it stops doing it but a day later the same problems happens again. Just want to know if there are any solutions that i can do before i take it to dealer.

Thanks!!
I actually have the same problem.. The touchscreen goes rogue and selects random things on the menu. At first i thought it was the physical center control buttons so i unplugged them only to find that didn't help. I originally had the touchscreen speed restriction disabled and would result in calls being made randomly and uncontrollably (radio station switching too). So after enabling it again, the problem only happens when stopped or at speeds <5 mph - which makes me think its the touchscreen malfunctioning.
Had the car brought to the dealer today, and they say it'll be an $800 cmu replacement. They refuse to believe the touchscreen is the issue (I could be wrong too but who knows)... regardless it sucks. Also worth mentioning they tried updating the system to no avail.

Hope you have better luck. :crying2: If you take it to the dealer, let me know what they say!
 

·
Registered
Joined
·
130 Posts
Discussion Starter #9
Well the problem still is happening intermittently. I think I will try a factory reset and then disconnect the battery for a while. I will also check the cables, but what cables should I be checking and do I need to remove the center console?

Thanks!
 

·
Registered
Joined
·
3 Posts
Hey all, my '14 is having this exact problem and this is the one place Google could find with somebody who has the same symptoms.

It did start intermittently for me - one day a few weeks ago the nav screen went all weird and tried dragging the cursor back and forth around middle the map. I restarted the car and it went away. Since then weird things have been happening on the screen with increasing frequency and today it's been nearly non-stop.

I originally thought it was a problem with the command controller knob, since it seemed to happen sort of randomly while I was sitting in the car with the navigation screen up, not touching any controls. The most common bug would be when I hit the back button to minimize the menu bar on the normal navigation map, the menu bar would almost instantly pop back up. This seemed to come and go but over the last week it happened more and more often.

It wasn't til today that I realized it could even be the touchscreen itself, but since I started looking for it I only noticed the bugs happening while I was under the 5 mph threshold or stopped. I've never modded or upgraded the infotainment system beyond the dealer-installed update last year so the normal lockouts are still active.


The touchscreen appears to be detecting a constant input on the upper-middle portion of the display, exactly where the "t" key is on the nav keyboard. I know it's (at least primarily) a problem with the touchscreen and not the command wheel because 1) the problems go away while the car is in motion and 2) the main audio screen functions normally, since there's no touch-interface items on that portion of the display on the audio screen. As soon as I open the input menu or the favorites menu the screen starts acting up again, but I can scroll left and right on the main audio screen menu with the control wheel with no issues.


The car is out of the bumper to bumper warranty so I'd like to at least try to fix it myself before taking it to the dealership. My best guess for an easy fix would be a loose connection between the display and whatever hardware actually runs the infotainment, but I have no idea where that is. I'd be willing to remove the central console and wiggle some stuff around but I don't have the time or space to disassemble and diagnose the entire dashboard.

I tried resetting the system by holding down FAV+NAV+MUTE, and by disconnecting the battery for about five minutes, but neither one did anything. I'm leaving the battery disconnected overnight but I'm not expecting that to fix it either.


If there's a more robust way to factory-reset the entire infotainment system I'll give that a shot, if somebody can show me how to do it. I'll take it to the dealer eventually but I don't expect them to fix it quickly or cheaply. I don't know if patinsd or vuruptor have made any progress since their last posts but it'd be nice to get this fixed - up til now I've been very happy with this car.
 

·
Registered
Joined
·
130 Posts
Discussion Starter #11
I am still having the same problem. The reset and disconnecting the battery didnt help. Now i put the screen into the main menu screen with the 5 icons and havent had any issues. only issues is when i change the display then the screen starts going rogue.....I also out of the warranty period so I am trying to fix this myself. If anything, I will take in the car to the dealership on the winter break.....
 

·
Registered
Joined
·
306 Posts
on time i had faced with other plat form touched let the firmware play crazy, such like you touch it and give command ... under magnifier after cleaning the touch found one small scratch which pushed forward the screen and it did make this contact ( as command ) each time when there shocking by moving.
 

·
Registered
Joined
·
300 Posts
Since the issue is only when the touch screen input is honored/enabled this has all the signs of a bad screen unit and not a CMU issue. This is because the link to/from the CMU & display is a secure digital data link. Due to that a loose connection from/to the screen from the CMU probably would also result in display corruption. In any case you could remove enough of the dash to see if the connectors on the CMU to the screen are loose. There is only one cable between them and power is an independent cable if I recall. Maybe check the fuses to the CMU/Infotainment system are secure - I don't know if the display is powered from it's own fuse or not but even a problem there is remote since no one is reporting the screen display acting up (scrambled video etc.) other than bogus touch activity.

Have you applied any cleaning products or screen protectors to the screen? I would first look at cleaning the screen but be careful that you don't get any cleaning liquid into the bezel around the screen. Also has any liquid been splashed onto the screen? Are you in a very high humidity area where condensation could have formed? Otherwise it probably is a bad touch screen overlay or electronics that only substituting a screen would confirm.

I guess you could take the screen portion (not CMU) apart to see if there are any loose cables internally or corrosion/damage. I suspect there are some ribbon cables to/from the screen to the electronics that could have worked loose. I've never seen any photos of the screen internals unlike those of the CMU.
 

·
Registered
Joined
·
422 Posts
From the first post you can clearly tell this is a touch screen issue and not a CMU. As others had said, it only acts up when sitting still because that is the only time the Touch screen is allowed to talk to the CMU.

The question is can you fix the touch screen and chances are you can't unless you are lucky enough that some dirt or buildup inside is applying pressure. Most likely the real fix will be to replaced the touchscreen. The work around would be to see if you can permanently disable the touch screen (sort of like the hack but in reverse).

Personally I find that I never use the touch screen. Most of the time I need it is when I'm moving and since it doesn't work, I have learned to use the controls so much that when I'm sitting still, I forget I have a touch screen all together... (maybe the lack of use will make it last longer) Between the controls, steering wheel, and voice.... I find the touch screen is only really helpful when typing in an address for Nav.

Good luck...and don't let the crappy dealer talk you into replacing the $800 CMU.
 

·
Registered
Joined
·
3 Posts
hi
i had the same problem and . . .
tried almost everything described before and in some point i went and replaced my screen to a new one.
and what a miracle - the problem gone!
P.S. i replaced it by warranty
 

·
Registered
Joined
·
3 Posts
hi
i had the same problem and . . .
tried almost everything described before and in some point i went and replaced my screen to a new one.
and what a miracle - the problem gone!
P.S. i replaced it by warranty
 

·
Registered
Joined
·
3 Posts
Since I made my last post the issue has been very intermittent. The screen will be fine for five days, then act up for four days, then go back to being fine for a week. There's no dirt or blemishes and I can't figure out anything that would trigger it.

I think the easiest out-of-warranty fix would be to disable the touch altogether, like da_jokker suggested. I only really use the touchscreen to enter navigation addresses, which can be done through voice commands instead.

I do have a third-party extended warranty, so if the problem comes back for good I'll take it in to the dealer and see if I can get the screen unit replaced.
 

·
Registered
Joined
·
422 Posts
Since I made my last post the issue has been very intermittent. The screen will be fine for five days, then act up for four days, then go back to being fine for a week. There's no dirt or blemishes and I can't figure out anything that would trigger it.

I think the easiest out-of-warranty fix would be to disable the touch altogether, like da_jokker suggested. I only really use the touchscreen to enter navigation addresses, which can be done through voice commands instead.

I do have a third-party extended warranty, so if the problem comes back for good I'll take it in to the dealer and see if I can get the screen unit replaced.
You might check with VoodooJef... not sure but I think he's parting out his 2016. Maybe he has a Touch Screen he'll sell ya.
 
1 - 20 of 221 Posts
Top