2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
297 Posts
Discussion Starter #1
So other to the odd small glitches that people are experiencing here's what happened to my car today.
Turn on the car, system says invalid SD card (all of a sudden). The system wont let me listen to any music, everything is greyed out.
After giving up I turn off the car do some shopping for a few hours, come back and this time.....the entire unit is now dead, just a pretty looking black screen. I pulled out the SD card and still nothing. Guess where I'll be tomorrow morning at 8am - yea, the dealer cause I have nothing else better to do LOL.
 

·
Registered
Joined
·
10 Posts
Got the very same problem!! Once I could not play any music I switched off and on my car and the ...all the infotainment was dead.. I was so upset since I was in the middle of a roadtrip.

I called customer service here in Mexico and they explained that it was a "security feature" since the system detected that I had been touching the screen while the car was moving (which in my opinion sounds like a pathetic excuse for a system glitch).

I'll have to go to my local dealership on monday to get it reseted. So disappointed of the quality of this new Mazda. I've owned two other Mazda in the past and they worked fine. This one...if it is not the infotainment is the suspenssion and other troubles...i guess that is what happens when you buy the first model of a new generation.
 

·
Registered
Joined
·
126 Posts
Got the very same problem!! Once I could not play any music I switched off and on my car and the ...all the infotainment was dead.. I was so upset since I was in the middle of a roadtrip.

I called customer service here in Mexico and they explained that it was a "security feature" since the system detected that I had been touching the screen while the car was moving (which in my opinion sounds like a pathetic excuse for a system glitch).

I'll have to go to my local dealership on monday to get it reseted. So disappointed of the quality of this new Mazda. I've owned two other Mazda in the past and they worked fine. This one...if it is not the infotainment is the suspenssion and other troubles...i guess that is what happens when you buy the first model of a new generation.
Wow that really sucks, I have been looking into buying a Mazda 3 I-touring or Grand Touring but kinda feel I should wait for the second roll-out :001_unsure:

What is wrong with the suspension? I haven't heard anything about that...
 

·
Registered
Joined
·
9 Posts
Same Problem

So I've had a few had a few issues with the Infotainment system since I got the car. A couple of times I would start the car and it would tell me that Navigation wasn't installed and it wouldn't recognize my USB music thumbstick. I found that restoring all factory settings would resolve this issue at the cost of losing all my settings and my Bluetooth pairing. So the same thing happened yesterday as I was set to head home from a short road trip, but this time it wouldn't even let me reset the settings to factory default :: the option was greyed out. So after saying a few choice swear words aimed at the car i just turned off the display and headed home. Now this morning I go to start up my car and the system doesn't even turn on. Black screen. Pushing the buttons does nothing. If anyone finds a fix please let me know I'm pretty peeved at the moment and I don't feel like taking the car in for a stupid software issue.
 

·
Registered
Joined
·
207 Posts
I called customer service here in Mexico and they explained that it was a "security feature" since the system detected that I had been touching the screen while the car was moving (which in my opinion sounds like a pathetic excuse for a system glitch).
I touched the screen a douzen times while driving, nothing happens... that's not an excuse in my I, that's a "We don't know it better" or, even worse, a simple lie to keep the customer on hold...!
 

·
Registered
Joined
·
207 Posts
Pushing the buttons does nothing. If anyone finds a fix please let me know I'm pretty peeved at the moment and I don't feel like taking the car in for a stupid software issue.
Did you try to pull the fuse for some time? I really don't know, but maybe helps...?
 

·
Registered
Joined
·
10 Posts
So I've had a few had a few issues with the Infotainment system since I got the car. A couple of times I would start the car and it would tell me that Navigation wasn't installed and it wouldn't recognize my USB music thumbstick. I found that restoring all factory settings would resolve this issue at the cost of losing all my settings and my Bluetooth pairing. So the same thing happened yesterday as I was set to head home from a short road trip, but this time it wouldn't even let me reset the settings to factory default :: the option was greyed out. So after saying a few choice swear words aimed at the car i just turned off the display and headed home. Now this morning I go to start up my car and the system doesn't even turn on. Black screen. Pushing the buttons does nothing. If anyone finds a fix please let me know I'm pretty peeved at the moment and I don't feel like taking the car in for a stupid software issue.
Exact same problem that I had...just as you described. Seems like it is a software issue. I tried to have it reset by pulling out the fuse but didn't work. Probably disconnecting the battery can solve it but didn't want to do that afraid of losing my warranty.

I' called my local dealer and they said I had to go today for a software update. Hopefully this will solve the problem, will let you know.:001_unsure:
 

·
Registered
Joined
·
10 Posts
I got it reset today at the dealer... They basically only disconnected and connected back the battery.

They said they are expecting to get the software update that fixes this glitch by the end of this month, since at least 10 customers have showed the same problem recently...
 

·
Registered
Joined
·
1,791 Posts
If I did this myself would it void the warranty?
Of course not. You have to disconnect the battery anyway for the installation of any of the electrical accessories.
 

·
Registered
Joined
·
97 Posts
Well, I went to the dealer over 2 weeks ago due to some problem with the screen. It had an imperfection under the glass and the dealer ordered a new part. Going Thursday to get it replaced and system updated. Good thing since in the past 2 days I've had it not boot once, add not work once, and reboot once. Add to that the screen is now cracked. Not the exterior glass but the screen. Probably cracked due to the existing imperfection and the negative degree temperature. Hit -8 this morning.
 

·
Registered
Joined
·
9 Posts
Disconnected the battery for about 10 seconds and reconnected it. Worked like a charm. The system came right back on; lost all my setting but NBD. If anyone else has the same issue you'll need a 10mm wrench to disconnect the ground terminal from the battery.

At first the navigation system said it wasn't equipped with the SD card inserted but then I remembered that I had been fiddling with the card and set the little switch on the SD card to locked in an attempt to fix the system while it was malfunctioning. Switched it back to unlock and everything was peachy.

Thanks Alfredcast for providing the info and saving me a trip to the dealer. Heres hoping that an update will save me the trouble of resetting it again, even though it was a simple fix.
 

·
Registered
Joined
·
10 Posts
If I did this myself would it void the warranty?
I asked the same question to the dealership customer service manager and he said it would not void my warranty. He said that if I wanted to have it done at the dealership next time that this happens he would be glad, though...

Next time I'll do it myself I think....lol
 

·
Registered
Joined
·
261 Posts
Well, I went to the dealer over 2 weeks ago due to some problem with the screen. It had an imperfection under the glass and the dealer ordered a new part. Going Thursday to get it replaced and system updated. Good thing since in the past 2 days I've had it not boot once, add not work once, and reboot once. Add to that the screen is now cracked. Not the exterior glass but the screen. Probably cracked due to the existing imperfection and the negative degree temperature. Hit -8 this morning.
I also had a defect in my screen. I believe the digitizer was de laminating.

Still no update done for me.
 

·
Registered
Joined
·
3 Posts
Had the same thing happened to me. Day one driving home from the dealership yesterday, it started to glitch and radio was greyed out. By the time I got it in the garage, it was totally dead.

I went in back to the dealer today to get it reformatted, but they happened to have v27 freshly available, so it's on there now. Good so far, but this is only day two! Haha.

On a side note, I noticed Bluetooth audio dropping yesterday with the previous version. Didn't skip a beat today, so that's a good thing.
 

·
Registered
Joined
·
113 Posts
I had the greying out and eventual dead screen today. It had the update upon delivery so the tech ruled that out. It turned out to be a fuse. If I understood him correctly, it wasn't in the slot correctly so there was a lack on connectivity.
 

·
Registered
Joined
·
8 Posts
Had the same thing happened to me. Day one driving home from the dealership yesterday, it started to glitch and radio was greyed out. By the time I got it in the garage, it was totally dead.

I went in back to the dealer today to get it reformatted, but they happened to have v27 freshly available, so it's on there now. Good so far, but this is only day two! Haha.

On a side note, I noticed Bluetooth audio dropping yesterday with the previous version. Didn't skip a beat today, so that's a good thing.
v27 you say eh? Time to schedule a trip down to Service!
 

·
Registered
Joined
·
10 Posts
Wow that really sucks, I have been looking into buying a Mazda 3 I-touring or Grand Touring but kinda feel I should wait for the second roll-out :001_unsure:

What is wrong with the suspension? I haven't heard anything about that...
I don't know yet what happens... I'll take the car to the dealer tomorrow.

A few weeks ago I noticed a strange noise everytime I was turning left on a rough road or passing a bump...I went to the dealer and took a quick tour with one of the service engineers. He heard the noise and said it could be either the suspenssion or an engine mount....

We will see after I take it to service tomorrow...

And yes, I would wait for the M3 2015. Will probably have many issues fixed.
 

·
Registered
Joined
·
13 Posts
Had the same thing happened to me. Day one driving home from the dealership yesterday, it started to glitch and radio was greyed out. By the time I got it in the garage, it was totally dead.

I went in back to the dealer today to get it reformatted, but they happened to have v27 freshly available, so it's on there now. Good so far, but this is only day two! Haha.

On a side note, I noticed Bluetooth audio dropping yesterday with the previous version. Didn't skip a beat today, so that's a good thing.
Purchased my GT on 1/30/13 and on 1/7/14 experienced the loss of radio and display indicated no navigation was installed. Thereafter the system shut down and the display went dark. Thanks to your post I was able on1/9 to educate my dealership that a V27 was available. They were unable to re start the system and thanks to this thread I convinced them to do a hard reset by pulling the battery cable. Mazda had yet to inform them of the update, but they were able to download it and install it.
I advised the dealership that it would be in their interest to maintain an email contact list of all their buyers with this system and preemptively advise them to come in for updates especially since Mazda USA doesn't appear to be doing it. They agreed. I told them that much like operating system software, the infotainment system has many moving parts and it can be expected that this process will continue for many revisions before it becomes stable; that the customer dissatisfaction that could be avoided would be worth the effort.

This level of service should be undertaken by the manufacturer. Perhaps a VP at Mazda should be sent a link to this thread. After all this is a great automobile and it would be a shame to have it not succeed for the kind of bad reputation this could engender.
 
1 - 19 of 19 Posts
Top