2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Hi, my. MZD Connect system (56.00.XXX forgot the last digits) keeps restarting. It hardly enter the home screen most of the time the screen stayed black or keeps on restarting by itself( radio working but could not change station), rear view camera isnt working.

sometimes while restarting the display will turn crazy like in the matrix movie( pictured below)

i have not installed any tweak whatsoever its pure stock and im out of warranty. Is there a way to fix this?
Also i plugged in some obd scanner and it says something like “CMU Memmory fault”.
277668

277667
 

·
Registered
Joined
·
43 Posts
Discussion Starter #2
Also i have tried hard reset it (Nav+Back+Mute), if the display is restarting it would then force restart but will again stuck while booting the restarts by itself automatically(endless loop).
If no display at all, if i were to press them nothing happens.
Also have tried removing car battery connector and fuse still the same
PS: this happens overnight did not do anything to the infotaiment screen no update os or install any tweaks
 

·
Registered
Joined
·
1 Posts
I'm sorry to say it, but your CMU is faulty, you need to replaced it. It's not that difficult. My brother's car was also with that problem, and I solved replacing the MCU ( I saw a tutorial on youtube). I spent $50 bucks for an used MCU on ebay. My Mazda dealer wanted to charged me $1300 bucks to fixed!!!!
 
1 - 7 of 7 Posts
Top