2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Completely stock 2021 Mazda3 Hatch, FWD, 2.5L, AT with < 1,000 miles is having repeated "In-Vehicle Network Malfunction" even after 3 repair attempts at Dealer and contacting Mazda.

1. Error appears at-random; no symptoms noted except MIL.
2. Vehicle is opt'd out of Connected Services, Connected Services are enabled in vehicle settings; opt-out was done by calling Mazda Support line.
3. The dealer has: 1) replaced the battery, 2) replaced the TCU, 3) cleared KAM.
4. If I attempt to enroll / opt-in to Connected Services using the MyMazda app it is unsuccessful (assuming because a server-side change was made by Mazda when I called to opt-out).
5. Some CX-30 owners report the same error related to GPS antenna; GPS / connectivity seems to work on the vehicle since the GPS itself works fine.
6. The error is being cleared by the dealer and seems to appear randomly after that.

I have another appointment with the dealer in 2 weeks (earliest they could get me in) and will keep posted here.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Update: the TCU (telematics) will need to be replaced again according to the Mazda Tech Line. Unfortunately, the part is on back order with no shipment date. Apparently the service part version is up to version D and my car, which has a replacement already, is version A.

In other news, due to multiple periods of time driving a loaner car, the CX-5 Bose != 3 Bose. Both are amazing, but the 3 is much more amazing.
 

·
Registered
Joined
·
1 Posts
Update: the TCU (telematics) will need to be replaced again according to the Mazda Tech Line. Unfortunately, the part is on back order with no shipment date. Apparently the service part version is up to version D and my car, which has a replacement already, is version A.

In other news, due to multiple periods of time driving a loaner car, the CX-5 Bose != 3 Bose. Both are amazing, but the 3 is much more amazing.
Hi their I have a 2019 Mazda 3 hatch and I’m having the same problem was yours ever fixed
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Hi their I have a 2019 Mazda 3 hatch and I’m having the same problem was yours ever fixed
Not yet. I took the car in again and was told the TCU would need to replaced, again. The service advisor told me they are on a higher revision part number than the one replaced previously. The part was in back order but just came so will post back after the Monday appointment to have it installed.

Note: after replacing the TCU last time it took time for the issue to recur.
 
1 - 7 of 7 Posts
Top