2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I am curious as to if any owners have began to experience intermittent hyperflash on one of your switchback turn signals? I've had this kit for about 1 1/2 years and my driver side switchback turn signal experiences hyperflash intermittently. It'll flash normally, then begin hyper flashing, then back to normal with no pattern whatsoever. I'm beginning to wonder if one of the load resistors are beginning to fail.
 

·
Registered
Joined
·
1,008 Posts
I hates those switchbacks. My drl's would randomly turn on and off, even though they were connected properly. My first set my driver side turn some LED's burnt out due to water leakage. I bought a second set and sealed them up good, but same thing the drl's would turn on and off. I could see the reflection, or non reflection in the cars in front of me.

I ended up buying the Revier ones which I love because they are smoked and not as bright, but just two days ago, my driver side drl stopped working. The turns on both sides work and the drl on the passenger is working. I will troubleshoot this weekend but I am thinking I need a new set.
 

·
Registered
Joined
·
578 Posts
If those fail you could try to get one of those new fog light DRL covers that have both DRL and turn signals integrated into them. I saw a few on eBay that looks good. They aren't switchbacks though.

I was considering to get some new fog light covers with the turn signals in them since one of the LEDs in one of mine burned out but it's hardly noticeable at all so I didn't.

If anyone is interested here's a few I found also note most sellers are from China so it might take a while to get to the states.

http://www.ebay.com/itm/63-LED-Daytime-Running-Light-DRL-Fog-Lamp-Turn-Signal-For-2013-16-Mazda3-Axela-/201788773376?fits=Year:2014|Make:Mazda|Model:3&hash=item2efb8c5400:g:RzkAAOSwEzxYSoZH&vxp=mtr
http://www.ebay.com/itm/LED-Light-Guide-Daytime-Running-Lights-DRL-LED-Fog-Lamp-for-Mazda-3-Axela-2014-/142258112796?fits=Year:2014|Make:Mazda|Model:3&hash=item211f3e891c:g:qC8AAOSwImRYM~1L&vxp=mtr
http://www.ebay.com/itm/LED-Daytime-Running-Fog-Lamp-DRL-with-YELLOW-TURN-Light-For-2014-2016-MAZDA3-/222204165463?hash=item33bc667d57:g:quoAAOSwIgNXnGWx&vxp=mtr switchbacks
http://www.ebay.com/itm/Fog-Lamp-DRL-LED-Daytime-Running-Light-For-Mazda-3-Axela-2014-Turn-Signal-New-/182350475570?hash=item2a74ef7132:g:V~oAAOSwXeJYJZPC&vxp=mtr these have an interesting design
 

·
Registered
Joined
·
13 Posts
I hates those switchbacks. My drl's would randomly turn on and off, even though they were connected properly. My first set my driver side turn some LED's burnt out due to water leakage. I bought a second set and sealed them up good, but same thing the drl's would turn on and off. I could see the reflection, or non reflection in the cars in front of me.

I ended up buying the Revier ones which I love because they are smoked and not as bright, but just two days ago, my driver side drl stopped working. The turns on both sides work and the drl on the passenger is working. I will troubleshoot this weekend but I am thinking I need a new set.
Same experience here, those drl switchback from ijdm sucks bigtime. My drl turn off when they get hot. The resistors need proper ventilation. Dont buy any ijdm DRL products. Better buy the VLEDS switchback. The build quality is superb. Im using them for 7 months now and not a single problem.

Sent from my ASUS_Z00AD using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Update:

After diagnosing the issue yesterday, half of the LED's on the turn signal strip were completely out. I suspect this dropped the current draw below the minimum threshold of the flasher unit, hence the hyper flash. I ended up just removing the whole kit and went back to the OEM signals.

VLED's may be in my future.
 

·
Registered
Joined
·
26 Posts
You guys are lifesavers.
My iJDM switchbacks are starting to do this exact same thing as well. Same problem too, the driver's side will start hyperflashing. The passenger side seems perfectly fine. I was about to go out and buy another pair of them, but if this is a common problem, which is seems that it is, then I'm just going to buy VLEDS instead and go back to the stock enclosure.

I really had high hopes for these switchbacks. I really liked them when they worked properly. But they just aren't worth the trouble if they're going to fail again after less than a year.
 

·
Registered
Joined
·
137 Posts
Hi,
Just seen this thread, I am in the same boat, passenger side issues, in fact the DRL is dead but the indicator still functions all be it fast!

Just orders a new set of ebay, cost was $70 so will see what happens

Any body seen and Audi style switchbacks? You they go from inside to outside in a line?

mark
 

·
Registered
Joined
·
137 Posts
HI Mike,
They were on flea bay, uk site. I discovered mine had taken a stone and let in moisture killing the LED DRL strip, fortunately the indicator piece still works!

I cant post a link here as its not allowed but the seller name was neverland-gbp

Hope this helps

TP
 

·
Registered
Joined
·
137 Posts
Hi Mike,
yep those are the ones. Best of luck let us know if you pick up the others
Mark
 

·
Registered
Joined
·
181 Posts
I've used this resistor and it works fine. No hyperflash.





This is how it works and comparison with the halogen bulbs and leds:

 

·
Registered
Joined
·
7 Posts
Does anybody still have one of this turn signals?
I like the smoked. But are the they bright enough and more important do they work more than just a few month?
 

·
Registered
Joined
·
227 Posts
I found 2 same switchback online from another source but it looks exactly the same as the ijdmtoy ones. Anyone tried or heard of these?

14-16 Mazda 3 LED DRL Turn Signal Lights Driving Lights With Switchback Function | eBay

https://www.ikonmotorsports.com/for-14-16-mazda-3-led-drl-front-signal-lights-with-switchback-function.html


Also taffyposh where did you see the $70 switchback?

UPDATE - it’s been 1 year and finally I experienced the same problem as everyone else with the driver side switchback. White led are gone and only signals work now. Gonna order a different type of switchback. Don’t bother getting this unless you only want yellow signal led and not use the white led drl function.
 
1 - 18 of 18 Posts
Top