2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
607 Posts
Discussion Starter #1
So I was listening to the radio (alpine unit) running wires for the Sirius box. I cut 2 wires that were attactched to the deck and it went dead. They were on the Aftermarket harness side, not the Factory harness.

So I checked the radio fuse, in the panel it is good, then I checked the fuse on the power wire for the radio it is also good.

I then slid out the aftermarket deck and put the OEM one in.
It also doesnt work.

Now my

Power door locks when the car is off dont work, when the car is running the button works
My Keyless entry never works.
My Radio (OEM or Aftermarket dont work)

My Tach never "Zero"s when I turn the car off, and I get a full gauge sweep everytime it goes to "acc" in when I turn the key.
 

·
Resident MacGyver
Joined
·
2,227 Posts
I won't tell you how bad of an idea it is to work on your stereo with the battery connected, much less with THE UNIT ON. Lol.

It sounds like you may have shorted wires and blown a fuse. Check the fuses under the hood. If you don't know where they are, check your owner's manual.
 

·
Registered
Joined
·
607 Posts
Discussion Starter #3
I know haha, I was hoping I could get away with it :(

Turns out it was the "room" fuse under the hood

15 amp. I only noticed cause my gauge lights wouldnt come on, and my dome lights, so I started looking for an Interior illumination fuse. And randomly pulled the room fuse out.
 

·
Registered
Joined
·
452 Posts
So you replaced it and everything is alright now?
 

·
Registered
Joined
·
412 Posts
"room" fuse? What in the hell is a "room" fuse? Is that something that didn't translate well from the original Japanese language engineering drawings???
 

·
Registered
Joined
·
331 Posts
I think something gets lost in the translation.

BeEvil
 

·
Resident MacGyver
Joined
·
2,227 Posts
Not to mention that the manual says the cabin fuse box is on the passenger side. This is only true for right-hand drive models. It's actually on the driver's side in the US. That confused the heck out of me, lol.
 
1 - 9 of 9 Posts
Top