2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi folks, this is my first post here. I'm working on my wife's new-to-her 2016 3 GT 6MT hatch with the factory lower body kit. The front "splitter" had come separated from the bumper (surprise?) because it's largely held together with foam tape. I was also putting in Hella Supertones and LED fogs, so I pulled the bumper off completely.

Behind the front bumper, sitting on top of the under-tray were these 2 heavy aluminum pieces. They look like clips or supports of some sort, but don't have an obvious positive-locking mechanism. The "inside" of the longer side has a rubber pad attached to it.

I'm putting the bumper back on tomorrow, so I'm hoping someone with more familiarity to these cars than I has some insight on where I should be putting these! Thanks!
 

Attachments

·
Mazda "E" Division
Joined
·
1,276 Posts
Hi folks, this is my first post here. I'm working on my wife's new-to-her 2016 3 GT 6MT hatch with the factory lower body kit. The front "splitter" had come separated from the bumper (surprise?) because it's largely held together with foam tape. I was also putting in Hella Supertones and LED fogs, so I pulled the bumper off completely.

Behind the front bumper, sitting on top of the under-tray were these 2 heavy aluminum pieces. They look like clips or supports of some sort, but don't have an obvious positive-locking mechanism. The "inside" of the longer side has a rubber pad attached to it.

I'm putting the bumper back on tomorrow, so I'm hoping someone with more familiarity to these cars than I has some insight on where I should be putting these! Thanks!
My guess it's from the OEM bodykit and it seems like they didn't use enough adhesive glue/bolts.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I was suspecting that, but I can't match them up to anything that makes sense and will secure them.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
what kind of adhesive did you use?
3M 5252VHB. I double-stacked it, though, because it was about half as thick as the original adhesive tape. I then clamped it all up overnight in a heated garage to allow it to set as well as possible.

It's worth noting that this car is a 2016. It seems that the kit changed a bit (front lip, at least) in 2017.
 

Attachments

  • Like
Reactions: MrBen
1 - 7 of 7 Posts
Top