2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello to everyone! Glad to announce I am new to this forum since I traded my mazda 6 3.0 for a 2004 mazda 3 this last week. Anyways here is my problem I traded the car knowing it had a "wiring issue" as the old owner stated. So first off the lowbeams don't work at all. Bulbs are good. Also hazards and turning indicators only work when high beam are on. Which talking about high beams they stay on all the time and I have to unplug them manually from the socket under the hood. The fog lights and angel eyes that were installed don't work either Does anyone have a clue to what this could be? Maybe fuses or relays?? Im just trying to get the car road ready lol THANKS! :smile2:
 

·
Super Moderator
Joined
·
5,553 Posts
Nothing to do with fuses or relays. The PO seems to have tried to install aftermarket lights and didn't have a clue maybe? Hope you know something about automotive wiring.:surprise:
There is also the possibility that the switch mechanism in the steering column is broken or otherwise screwed up and/or tampered with.
I would remove everything that the PO tried to install, rewire the stock lights if they are still on the car then go from there.:dunno:
 

·
Working Class Hero
Joined
·
3,602 Posts
Nothing to do with fuses or relays. The PO seems to have tried to install aftermarket lights and didn't have a clue maybe? Hope you know something about automotive wiring.:surprise:
There is also the possibility that the switch mechanism in the steering column is broken or otherwise screwed up and/or tampered with.
I would remove everything that the PO tried to install, rewire the stock lights if they are still on the car then go from there.:dunno:
This.

Sent from a Samsung that doesn't explode.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Headlight problem (continued)

Hello everyone, my Mazda 3 headlight problem is still here and I was wondering if it's the the light Colum switch. What the headlights are doing is...So first off the lowbeams don't work at all. Bulbs are good. Also hazards and turning indicators only work when high beam are on. Which talking about high beams they stay on all the time and I have to unplug them manually from the socket under the hood. The fog lights don't work either. Could it also be the headlight wiring? If so how hard is that to replace? Thanks !
 

·
Super Moderator
Joined
·
5,553 Posts
You don't need to start a new thread, just update the one you started.
Did you disconnect the aftermarket hack job lights?
As to how hard it would be to rewire the lights, that depends on how bad the PO hacked the wiring. :shocked013:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
UPDATE: I paid $30 for a new headlight/blinker switch on the steering colum and that didn't resolve the issue. I don't be have a clue on how to rewire the headlights so does anyone have a clue to what'd it cost to have it done? Hopefully not to much since I'm a high school student working a minimum wage job to fix this car up.
 

·
Registered
Joined
·
267 Posts
See if a shop will diagnose/evaluate if they can see the issue without too much poking for free. Sounds like a terrible wiring job from someone that didn't want to take the time to figure out how things worked first.
 
1 - 7 of 7 Posts
Top