2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 ·
Hey guys, I have a 2018 Touring and was successful in disabling the DRL's, but for some reason I can't re-enable them. The process I'm using is:

(with parking brake off)
Press "START" twice
Press and hold foot brake (throughout entire process)
Enable parking brake
Move light control stalk from "Off" to "=|) (|=" (parking lights) FIVE times, ending in the "Off" position
Enable and disable hazard lights FIVE times, ending with the hazards disabled
Move light control stalk from "Off" to "=|) (|=" (parking lights) FIVE times, ending in the "Off" position
Remove foot from brake pedal
Start car, disable parking brake, drive forward to test.

What am I doing wrong?
 

·
Registered
Joined
·
570 Posts
Maybe this is your omen for disabling one of your car's safety features which is proven to prevent accidents based on several years of factual data. Check your insurance policy...you probably even got a discount for those DRL's.
 

·
Registered
Joined
·
47 Posts
Hey guys, I have a 2018 Touring and was successful in disabling the DRL's, but for some reason I can't re-enable them. The process I'm using is:

(with parking brake off)
Press "START" twice
Press and hold foot brake (throughout entire process)
Enable parking brake
Move light control stalk from "Off" to "=|) (|=" (parking lights) FIVE times, ending in the "Off" position
Enable and disable hazard lights FIVE times, ending with the hazards disabled
Move light control stalk from "Off" to "=|) (|=" (parking lights) FIVE times, ending in the "Off" position
Remove foot from brake pedal
Start car, disable parking brake, drive forward to test.

What am I doing wrong?
I have the same model, you prob should've just removed the 15A fuse. Fuse location #15 It's much easier...

Try disconnecting your battery negative cable for about 30 seconds or so then reconnect.

I'm enjoying DRL free on my 18 touring!
20180730_081608.jpeg


Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
24 Posts
I have the same model, you prob should've just removed the 15A fuse. Fuse location #15 It's much easier...

Try disconnecting your battery negative cable for about 30 seconds or so then reconnect.

I'm enjoying DRL free on my 18 touring!
View attachment 251581


Sent from my SM-G930V using Tapatalk
i also attempted the button pressing thing on my 2015 mazda 3 but after many failed attempts, i just pulled the associated fuse from the box and was able to safe keep it in the lid incase i needed to turn them back on :)
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #5 ·
I'm trying to re-enable the DRL's, though...

Do you think disconnecting the battery might reset that setting?
 

·
Codger
Joined
·
73 Posts
FWIW, my DRLs don't activate below 15 mph. Are you sure they aren't working above that speed?
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #9 ·
I figured it out...you have to hold the BRAKE pedal down for about 3 seconds after completing the process. I suppose in my eagerness to re-enable them I didn't allow the system enough time.
 
1 - 9 of 9 Posts
Top