2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
So My 2017 Mz3 GS is having issues with the GPS. I bought it back in 2021, got the SD card off Amazon, updated the maps, put in my car, etc. Worked fine till about 2 months ago. It would to freeze at locations, or be on wrong roads... hell, I even drove through Lake Erie apparently.

Anyways, I tried a ton of things on here and other forums. Disconnected the battery, did a full factory reset, took out the SD/reinserted, even just upgraded to the latest firmware (74.00.311). I also took apart the console area, disconnected the antenna/CMU and then did the previous again just in case.

My "Available Satellites" are 0 when I look at the GPS. Removing the SD and checking the compass it's stuck at N and -- for Long/Lat coordinates.

When the SD car is in, it's showing San Antonio, Texas.. I live in Toronto, Canada so it's a bit of ways off.

For comparison, my wife's 2017 CX-5 GT has 0 issues with the GPS/Nav, even in our garage lol.

Has anyone else run into this? Could the antenna have failed?

Mazda said they won't cover this, does anyone know a 3rd party replacement? Or even an upgraded one (if it exists)?

EDIT
It appears I have a DTC in there B119F:13 - GPS Antenna-Circuit open
 

·
Registered
Joined
·
4 Posts
So My 2017 Mz3 GS is having issues with the GPS. I bought it back in 2021, got the SD card off Amazon, updated the maps, put in my car, etc. Worked fine till about 2 months ago. It would to freeze at locations, or be on wrong roads... hell, I even drove through Lake Erie apparently.

Anyways, I tried a ton of things on here and other forums. Disconnected the battery, did a full factory reset, took out the SD/reinserted, even just upgraded to the latest firmware (74.00.311). I also took apart the console area, disconnected the antenna/CMU and then did the previous again just in case.

My "Available Satellites" are 0 when I look at the GPS. Removing the SD and checking the compass it's stuck at N and -- for Long/Lat coordinates.

When the SD car is in, it's showing San Antonio, Texas.. I live in Toronto, Canada so it's a bit of ways off.

For comparison, my wife's 2017 CX-5 GT has 0 issues with the GPS/Nav, even in our garage lol.

Has anyone else run into this? Could the antenna have failed?

Mazda said they won't cover this, does anyone know a 3rd party replacement? Or even an upgraded one (if it exists)?

EDIT
It appears I have a DTC in there B119F:13 - GPS Antenna-Circuit open
I battled with an unstable GPS on my 2016 Mazda 3 for 3 years and finally think I found the problem. I had a different error code which indicated a low voltage to the CMU. The problem appears to be a loose connection from the battery to the fuse box, which I think I corrected.

I had replaced the GPS antenna hoping that was the problem (it wasn't). I bought the part online (about $55 USD) and installed it myself. It's mounted next to the center speaker above the dashboard. You just have to open the cover grille using a small pry tool to release the locking tabs.

I doubt that the GPS antenna is bad - you just have a bad connection. so open the grill to access the GPS antenna and check to connector to the line that goes to the CMU. If that doesn't fix the problem, you'll have to check the connection at the back of the CMU. It's a little harder to access - there are YouTube videos that show how to do it. There is also the possibility that the connector wire from the GPS antenna to the CMU has shorted or failed (unlikely). If you take it to the dealer, I'm guessing it would be about a $200 job (including parts, if needed).
Automotive design Font Automotive exterior Parallel Pattern
 

·
Registered
Joined
·
4 Posts
And there are some CMUs with a GPS problem... in case of CX-5 up to part number with letter H at the end. I got mine replaced due to wrong places shown while navigation (in warranty time).
Thanks. Yes, I heard that previously, but mine has been out of warranty for about 3 years. So far, my fix has worked ok (bad connection from battery to fuse box). Holding my breath. I bought a new SD card on e-bay a few years ago but I think it was counterfeit (they are easy to copy, but I think Mazda has crack down on them). I'm hoping my GPS is fixed, but I'm tempted to do the retrofit so I can use Android Auto and not have to worry about map updates and GPS going out at the worst times.
 
1 - 5 of 5 Posts
Top