2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter #1
I already have Nav. I have used the toolbox to backup the card (and update it). However I would rather put the OEM SD card in a safe place and run my NAV from a 2nd card.

I'm not looking for any hacks... just looking for SD cards that are readily available (like from Amazon) that people have been able to successfully restore their backup to and use.

I've been searching and found some post. One person had tried 3-4 aftermarket cards and none worked. One guy linked a card he says worked, but the link is dead.

FYI... looks like the stock card is only an 8GB so doesn't seem like I need to go out and buy some 32/64 GB card.
 

·
Registered
Joined
·
327 Posts
Grab any name brand 8GB card and try a restore from your backup?
 

·
Registered
Joined
·
148 Posts
Just updated my nav maps as well and this seems like a good idea; if you dont mind, share the card you decide buying once you confirm it works to restore a backup to. Thanks!
 

·
Registered
Joined
·
422 Posts
Discussion Starter #5
WARNING: for those that don't have enough free cash to buy Nav all over again, you better get on this! It is down right scary (and messed up) what Mazda has done to "protect" their Nav.


So I ran down to walmart and for $11 bought a SanDisk Ultra Plus SDHC UHS-I Card 16 GB. I specifically targeted this one because it blows the doors off normal Class 10 cards with a 80 MB/s speed (typical is 30-45).


So plopped the card in my laptop and it was already formated as FAT32 (check).... only had 1 partion (check) ..... and didn't have any pre-existing files (check).

Opened up the Mazda Tool box and it would NOT get past the opening screen because the detected card was NOT valid. Of course it is not valid Mazda... my dog just ate my $400 card and now this is a blank I want to restore my LEGIT backup to!

So I copied all the files from my OEM SD Card to this new one (just using Windows Explorer). The Mazda Tool box then would at least recognized the SD card and let me get past the opening screen.

But wait... still not out of the woods.... I tell MazdaToolbox that I want to restore by backup.... it fails to initialize... not because of the card, but because the software apparently can't communicate with the Mazda Server? So Now I'm logged into this POS software (which required a Mazda server connection to validate), managed to get past the opening screen, and NOW you won't let me restore my LEGIT backup because you claim you can't talk to your flipping server for some reason???? WTF!!!

So right now, I'm trying a different fork in the FU Mazda road and allowing the MazdaTool box to "Apply an Update" to see if that works....

So basically what Mazda is telling us is that not only did you have to buy Nav for $400, but if ANYTHING happens to your original SD card, OR if our software can't talk to our servers to restore your backup, OR you have fallen out of your initial subscription period, you get to go buy another $400 card from us because we bent you over.

No wonder people hack this shit........going legit get's you shafted.
 

·
Registered
Joined
·
306 Posts
So I copied all the files from my OEM SD Card to this new one (just using Windows Explorer). The Mazda Tool box then would at least recognized the SD card and let me get past the opening screen.
But wait... still not out of the woods.... I tell MazdaToolbox that I want to restore by backup.... it fails to initialize... not because of the card, but because the software apparently can't communicate with the Mazda Server? So Now I'm logged into this POS software
Naviextras Tool, if you had sync before yours Original Card, all the most important file such DP.zip and yours device.nng and device.0 yours Licences include the update one. were saved at hidden PC "appdata" from there you can take the important files.
2- you had make full SDCARD and you asked TOOL to make Restore ? how it come?? the procedure should be make backup .. then choice restore to ask you insert blank SDCARD.

let us being little fare.. till now no issue remarked for backup and restore with this tool unless the slow download
 

·
Registered
Joined
·
422 Posts
Discussion Starter #7
So restore didn't work, trying to update got stuck. Each to their own, but this is what I just did and it works.

1) Completely uninstalled MazdaToolbox. It was taking up way too much room on my hard drive because it had 2 different backups (that are worthless), plus the downloaded Update that I already had. Re-Installed afterwards for "future updates". Once my subscription runs out, will probably remove it all together.... so basically... I'm using this tool just to update an SD card... and will "SKIP" any and all future prompts for backups.

2) I deleted all the files on my new $11 SD card.

3) I used windows explorer to copy all the files off my OEM SD card that I had just updated to the latest version. I placed a copy of all the contents in a "safe place".

4) Inserted in my new "blank" SD card and copied all those files to it.

5) Placed the new $11 SD card into my Nav, booted up the car and all is well. Now I will file the original OEM away.



So long story short, the only real backup is to make sure to copy all your files (including hidden ones) off your existing, working, and updated SD card to someplace safe. Then you can restore by just copying them back to any SD card (more or less), bypassing the Mazda Toolbox all together.
 

·
Registered
Joined
·
422 Posts
Discussion Starter #8
So because there was so many threads on this, I'm posting my latest followup on each (including my own thread of course).... Just as an FY for anyone that may come accross this...


So a followup for me. Used the copy and paste method to make my clone and been running with that backup card until today (so almost a month). I drove somewhere and my navigation was working (which I only know because speed signs were showing in the hud). Started the car to come home and navigation wouldn't load and the speed signs were gone.

When I got home I put the aftermarket SD card in the laptop and the Mazda toolbox recognized it, said there was no update for it, but when I tried to validate, it failed complaining about the VIN number (I think it was). Once again I tried to restore to the aftermarket card and it wouldn't work....it would time out saying that it could not connect to Mazda servers.

I then downloaded an old program called win32image and used it to makes a clone of my original. Once done the Mazda toolbox past the aftermarket SD card with flying colors and this morning everything was back to normal.

So looks like SD cloning software may be better than this toolbox POS, which is only good for downloading the latest maps.
 

·
Registered
Joined
·
327 Posts
Did you try shutting the system down and back on before pulling the card to your computer?

Just asking cause my Nav glitched on my yesterday in almost the exact same way as you. Left work, put home in the GPS. Stopped for gas, filled up. Got back in the car and took off.

A few minutes down the road I notice I don't have traffic signs or turn directions on the HUD. I hit the NAV button and a compass is on the screen saying I have NAV but need an SD card. I removed and re-inserted the card at a street light, the system recognized both but it was flagging it as an invalid card.

I pulled into a lot, shut the car down for 30 seconds, started it back up and everything was good again.

It's the first real glitch I've had, doesn't concern me too much but thought it was weird after seeing your post.
 

·
Registered
Joined
·
18 Posts
nav system and music is flakey to say the least.

Im searchin around to see if others are having the same problem
I have a cx9 with nav, Im a long time Mazda fan, but the stupidity of the programming in this vehicle is ....
and my best advice would be to carry an ipod and Garmin gps as many times I have started on a trip only to find the nav doesnt boot up, most of the time if you pull over and restart the car it works, but not always. Yesterday on a 1800 km trip both the music and nav wouldnt boot, I pulled over in a blinding storm to see if I could just reboot but to no vail so the last few hours was without music but at least my Garmin worked. And as usual when I stared it this am to go and complain to Mazda everything worked.:frown2:
 

·
Registered
Joined
·
306 Posts
there are only one issue remarked that the SDCARD Socket some time glitch to read the card, and this normal even over PCs with built in sdcard reader socket , in Mazda sadly to say its very cheap variant socket , the small switch plate some time make distances to base so no contact any more. result error showed no SDCARD. for general maintenance if you always take the card out and in again will cause this issue. use air spray to clean inside the socket and keep the card remain in. then no issue any more you will face at future. if it remain glitch go to dealer to replace for you the SDCARD socket.
 

·
Registered
Joined
·
25 Posts
Using ISOCreator,
Create a ISO image your SD card in its virgin state (completely unused)
Create another ISO of the SD card after it has been used on the vehicle, this will be the most reliable backup of the Original SD Card. You can also use this image to make clones of your original SD Card.
 

·
Registered
Joined
·
111 Posts
By the way. The newer Infotainment s/w versions writes the VIN number to the SD card a couple of minutes after the car is started. It no longer waits until you have driven a few miles with a new card.
 

·
Registered
Joined
·
673 Posts
You need to use an imaging program to replicate the SD card. I use the following procedure which works for me:

1. Backup and update the original SD card in Mazda Toolbox
2. Copy an image of the OEM SD nav card to a chosen directory on your PC using Win32DiskImager
3. Restore the image in step 2 to backup your SD card using Win32DiskImager
4. Adjust the partition size on the SD card if required using MiniTool Partition Wizard
5. The backup SD card should now work in your car
 

·
Registered
Joined
·
569 Posts
You need to use an imaging program to replicate the SD card. I use the following procedure which works for me:

1. Backup and update the original SD card in Mazda Toolbox
2. Copy an image of the OEM SD nav card to a chosen directory on your PC using Win32DiskImager
3. Restore the image in step 2 to backup your SD card using Win32DiskImager
4. Adjust the partition size on the SD card if required using MiniTool Partition Wizard
5. The backup SD card should now work in your car
In the US, no programs or partition adjustment needed: Just add new folder to your desktop and copy the updated files and then paste into the new folder on your desktop. The 2 files inside the folder need to be copied and pasted separately. One file takes just a few seconds and the 2nd file takes several minutes. Depending on speed of your computer total time per SD will take 5-10 minutes. In my case, I keep the original Mazda SD at home for safe keeping, one copy in the nav system, and the 2nd copy in the car as well. I use Sandisk High Speed 16 GB cards without any issues. Some people have indicated cheap knockoffs or even an SD card with too much memory have caused them issues in regards to being recognized in the Nav system.

All the programs and imaging that others are suggesting is extra work and not needed in order to make the copies work in the nav system...at least in the US.
 

·
Registered
Joined
·
60 Posts
I have no idea what I'm doing wrong then.
I'm in the US, Mazda Connect version 546 (I tried when I was at 502 too).
I've tried manually copying and using an image from Rufus USB and Win32ISOCreator.
Here's the thing though, the SD card is recognized and the Nav screen comes up, BUT no streets show up and no POIs. Just the landscape. If I pop in the real SD card, everything works/displays correctly.
Any ideas?
 

·
Registered
Joined
·
569 Posts
I have no idea what I'm doing wrong then.
I'm in the US, Mazda Connect version 546 (I tried when I was at 502 too).
I've tried manually copying and using an image from Rufus USB and Win32ISOCreator.
Here's the thing though, the SD card is recognized and the Nav screen comes up, BUT no streets show up and no POIs. Just the landscape. If I pop in the real SD card, everything works/displays correctly.
Any ideas?
nxt, not sure if you are responding to me. Read thru my instructions again below about just copying/pasting. Consider trying a different SD card...that has been a known/common issue. Before you even put the copy in the car nav system, check it in Mazda tools as well to see if it recognizes it. A working copy is recognized by Mazda tools as a legitimate card just as the original. Also, when removing the SD from the computer, eject properly using the taskbar. Many times/most of us don't without any issues, but this a known problem which can occur anytime we eject media from our computers, causing either minor or major corruption problems with data.

The exact SD I use is the Sandisk Ultra 80mb/s 16GB without any issues.

If you are doing it correctly then the only issue would be the card itself.
 

·
Registered
Joined
·
60 Posts
nxt, not sure if you are responding to me. Read thru my instructions again below about just copying/pasting. Consider trying a different SD card...that has been a known/common issue. Before you even put the copy in the car nav system, check it in Mazda tools as well to see if it recognizes it. A working copy is recognized by Mazda tools as a legitimate card just as the original. Also, when removing the SD from the computer, eject properly using the taskbar. Many times/most of us don't without any issues, but this a known problem which can occur anytime we eject media from our computers, causing either minor or major corruption problems with data.

The exact SD I use is the Sandisk Ultra 80mb/s 16GB without any issues.

If you are doing it correctly then the only issue would be the card itself.
Thanks, yeah I've done that and Mazda Toolbox recognized it too.
But I'm going to try again and have Mazda Toolbox update the map (even though I already have the latest), so maybe it'll redownload official map and make it work on this Sandisk 16GB I have :) I'll reply again with my result.
 
1 - 19 of 19 Posts
Top