2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

321 - 336 of 336 Posts

·
On that college budget
Joined
·
5,278 Posts
Discussion Starter #321
Well. If you have the rubbing issue. Marty says an upgraded RMM will fix the issue. @Crespo has no issue with a JBR 80 RMM but @pro had the issue with the CS inserts. If you don't want to purchase a RMM because of money reasons or just don't want the vibes just use the hose clamps like we have. I haven't had an issue since.

Also, be sure to use some RTV on the flange that connects the midpipe and flexpipe as both me and @pro had exhaust leaks there. Just trying to save you all some time and frustration!
 

·
Registered
Joined
·
51 Posts
Also, be sure to use some RTV on the flange that connects the midpipe and flexpipe as both me and @pro had exhaust leaks there. Just trying to save you all some time and frustration!
What rtv did you use? I used some exhaust putty and after a week and half, it started to fall off. I have a very small leak, but its enough to notice.
 

·
Registered
Joined
·
518 Posts
Hey everyone. been out for a bit. Got some reading to catch up on. overall, hows the headers?
 

·
Registered
Joined
·
130 Posts

·
On that college budget
Joined
·
5,278 Posts
Discussion Starter #329
Small difference but it is noticeable. Going to be catless soon with a tune so it will be a big difference then dyno time to see how much power I'm making :)
 

·
Registered
Joined
·
518 Posts
Nice, my lil MIA set me back a good while before installing them, it makes me sad to see mine sitting here everytime i pass by it.
 

·
ZOOM'IN around Mid-Ohio
Joined
·
212 Posts
Mines on but also had the upper sensor issue. When I finally did get it the threads were corroded and disintegrated. Hope to finish Tuesday.
 

·
Registered
Joined
·
37 Posts
I was not a part of the group buy, but i just installed my MSDS header last week...

One thing i had to do was take a cut off wheel and open the slit to allow room for the bolt to tighten the flex pipe onto the header. i had tightened it all the way it and it was still loose, the trimming of material there allowed for more tightening capability, that fixed my leak issue you guys are talking about without rtv.

I also had an idea to get rid of the CEL... i bought a racepipe from Corksport to add to my corksport exhaust when i did this install last week, so i have my second cat laying in storage. My CEL came on after 40 miles or so even with the non-fouler trick. I ordered a 90 degree elbow and extension online and im going to pull some of the catalyst out of my secondary cat to stuff inside of the elbow. In theory it should work... does anyone have any experience or heard of anyone else trying this?
 

·
Silver Surfer
Joined
·
2,904 Posts
I was not a part of the group buy, but i just installed my MSDS header last week...

One thing i had to do was take a cut off wheel and open the slit to allow room for the bolt to tighten the flex pipe onto the header. i had tightened it all the way it and it was still loose, the trimming of material there allowed for more tightening capability, that fixed my leak issue you guys are talking about without rtv.

I also had an idea to get rid of the CEL... i bought a racepipe from Corksport to add to my corksport exhaust when i did this install last week, so i have my second cat laying in storage. My CEL came on after 40 miles or so even with the non-fouler trick. I ordered a 90 degree elbow and extension online and im going to pull some of the catalyst out of my secondary cat to stuff inside of the elbow. In theory it should work... does anyone have any experience or heard of anyone else trying this?
Why don't you plug up the o2 sensor.. get an O2 sensor with a longer wire have an exhaust shop weld you a bung after the second cat. screw it in aaaaaaand CEL gone (hopefully) :stuart:
 

·
Registered
Joined
·
37 Posts
Why don't you plug up the o2 sensor.. get an O2 sensor with a longer wire have an exhaust shop weld you a bung after the second cat. screw it in aaaaaaand CEL gone (hopefully) :stuart:

Second cat is non existent.... racepipe baby! my new buddy @Kjensenmich who i bought the headers from told me he did the second cat O2 thing you suggested and the light still came on after a while
 

·
Silver Surfer
Joined
·
2,904 Posts
Second cat is non existent.... racepipe baby! my new buddy @Kjensenmich who i bought the headers from told me he did the second cat O2 thing you suggested and the light still came on after a while
Light will always come on no matter what you do unless you permanently disable the code. Every solution you find will eventually get beaten by the fact that you don't have a cat where it should be.. Best bet is to get a tuner to disable the code or mickey mouse the setup every time it pops up.
 
321 - 336 of 336 Posts
Top