2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi all. If someone is able to point me to a more suitable thread for this query that would be great. Otherwise ...

When turning the ignition to start the car there is an audible 'tap' sound from behind me - like someone has gently tapped something with a wrench - again, not loud but noticeable to the me, the driver. My 08 Mazda 3 never made that noise. Over time I'm concerned it could be a fuel pump going bad - which seems odd is my car has done less than 50,000km/32,000m. Would love anyones thoughts. Is my thinking even on the right track thinking it's a fuel pump issue?

I have a few other issues I'd like to bring up but not quite sure which forum to engage with.

Thanks!
 

·
aka Goodwrench
Joined
·
29 Posts
To verify if it is the fuel pump, just turn the ignition to the ON position without starting the car.
The fuel pump will run for a few seconds and then stop. If there isn't a "tap" sound it is not he fuel pump.

My guess would be something on the exhaust.
Maybe a broken exhaust hanger. When the engine first starts up, the entire exhaust system
gets a bit of a jolt.

If you can get under the car, when cold give the exhaust a good shake.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Thanks for the reply. Tested your theory and there was no noise.

To be honest I suspected it could be the exhaust knocking against something on startup. I'm not sure why my mind went straight to the fuel pump.

I haven't got underneath yet but I reckon you're right.

Thanks again!
 
1 - 3 of 3 Posts
Top