2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter · #1 · (Edited)
Could somebody help me to fix proble in my fog light?

Last saturday, i've equiped led fog lights projector to my car, i wired it's to the fog lights....

After that, i try to turn it on, it turned on with fog lights like i expected, in the evening i start the car engine on and turn the fog lights on, it bright on 20 second and suddenly turn off.

I think may be of headlight off timer, but the car engine is on so can't be headlight off timer...., i try turn the headlight, fog light switch off and then turn them on, only the low beam and Side Marker Light are on... both of fog lights are of...

Check the service manual, i think it may be the fuse was broken, but when check the fog light fuse (the fuse number 1 of fuse box in engine bay), it fine.

Check the fog lights bulb, it fine too...

May be the fog lights relay is the problem, but i not yet check it....

Do anybody facing with that problem and how to fix it?

Thank and best regards!
 

·
Super Moderator
Joined
·
6,384 Posts
A little confusing.... :confused1 1:
What is the projector light you wired to the fog lights? What are you using for a switch? Are you using the fog light plugs that are installed behind the bumper or did you wire the power from the headlight? Did you check all the fuses, not just the fog light fuse?
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #3 ·
A little confusing.... :confused1 1:
What is the projector light you wired to the fog lights? What are you using for a switch? Are you using the fog light plugs that are installed behind the bumper or did you wire the power from the headlight? Did you check all the fuses, not just the fog light fuse?
It Led fog lights projector, I wired it to the OEM fog light plugs, it will turned on with fog light from fog lights original switch.

I've check the fog lights fuse and some fuse on Fuse box in engine bay.... not all of them...

Thank!
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #4 ·
Yesterday, i've check the fog relay and FBCM box, all work good.... i'm confused and don't know what happend to my car.... i'll check wire of fog lights.....

Could anyone have advice for my problem?

Thank and best regards!
 
1 - 4 of 4 Posts
Top